aboutsummaryrefslogtreecommitdiff
path: root/security/pulledpork/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/pulledpork/Makefile')
-rw-r--r--security/pulledpork/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/security/pulledpork/Makefile b/security/pulledpork/Makefile
index 0e8620c338e1..2921a42f4f65 100644
--- a/security/pulledpork/Makefile
+++ b/security/pulledpork/Makefile
@@ -1,4 +1,4 @@
-# Create by: Olli Hauer
+# Created by: Olli Hauer
# $FreeBSD$
PORTNAME= pulledpork
@@ -7,6 +7,10 @@ PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PATCH_SITES= ${MASTER_SITE_LOCAL}
+PATCH_SITE_SUBDIR= ohauer
+PATCHFILES= ${PORTNAME}-${PORTVERSION}-r${PATCHREV}.diff.bz2
+
MAINTAINER= ohauer@FreeBSD.org
COMMENT= Script to update snort-2.8+ rules
@@ -16,6 +20,8 @@ RUN_DEPENDS= p5-Crypt-SSLeay>=0.57:${PORTSDIR}/security/p5-Crypt-SSLeay \
p5-LWP-Protocol-https>=6.00:${PORTSDIR}/www/p5-LWP-Protocol-https \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+# 0.6.1 -> svn rev. 230
+PATCHREV= 230-262
NO_BUILD= yes
USE_PERL5_RUN= yes
@@ -33,7 +39,9 @@ PLIST_FILES= bin/pulledpork.pl \
SUB_FILES= pkg-message
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= LICENSE README README.CATEGORIES README.CHANGES README.RULESET README.SHAREDOBJECTS
.endif
@@ -60,7 +68,7 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/contrib/README.CONTRIB ${DATADIR}/
@${INSTALL_SCRIPT} ${WRKSRC}/contrib/oink-conv.pl ${DATADIR}/
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}/
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/