aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot-dns-digitalocean/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-certbot-dns-digitalocean/Makefile')
-rw-r--r--security/py-certbot-dns-digitalocean/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/py-certbot-dns-digitalocean/Makefile b/security/py-certbot-dns-digitalocean/Makefile
new file mode 100644
index 000000000000..fedf61b647ff
--- /dev/null
+++ b/security/py-certbot-dns-digitalocean/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= certbot-dns-digitalocean
+PORTVERSION= ${ACME_VERSION}
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= DigitalOcean DNS Authenticator plugin for Certbot
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION}:security/py-acme@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION}:security/py-certbot@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-digitalocean>=1.11:www/py-python-digitalocean@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${FLAVOR}
+
+.include "${.CURDIR}/../py-acme/version.mk"
+.include <bsd.port.mk>