aboutsummaryrefslogtreecommitdiff
path: root/security/py-google-auth-oauthlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-google-auth-oauthlib/Makefile')
-rw-r--r--security/py-google-auth-oauthlib/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/security/py-google-auth-oauthlib/Makefile b/security/py-google-auth-oauthlib/Makefile
new file mode 100644
index 000000000000..4b2f13931a80
--- /dev/null
+++ b/security/py-google-auth-oauthlib/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= google-auth-oauthlib
+PORTVERSION= 0.4.4
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Google Authentication Library
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-auth>=1.0.0:security/py-google-auth@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0:www/py-requests-oauthlib@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>