aboutsummaryrefslogtreecommitdiff
path: root/security/py-otr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-otr/Makefile')
-rw-r--r--security/py-otr/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/security/py-otr/Makefile b/security/py-otr/Makefile
new file mode 100644
index 000000000000..b8b44d2674b7
--- /dev/null
+++ b/security/py-otr/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-otr
+# Date created: 2010-26-03
+# Whom: Frank Steinborn <steinex@nognu.de>
+#
+# $FreeBSD$
+
+PORTNAME= otr
+PORTVERSION= 0.2.1.1
+CATEGORIES= security python
+MASTER_SITES= http://python-otr.pentabarf.de/releases/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-otr-${PORTVERSION}
+
+MAINTAINER= steinex@nognu.de
+COMMENT= A set of python bindings for libotr
+
+BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/swig13
+LIB_DEPENDS= otr:${PORTSDIR}/security/libotr
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= python-otr
+
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>