aboutsummaryrefslogtreecommitdiff
path: root/security/py-pycrypto/files/patch-setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-pycrypto/files/patch-setup.py')
-rw-r--r--security/py-pycrypto/files/patch-setup.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/security/py-pycrypto/files/patch-setup.py b/security/py-pycrypto/files/patch-setup.py
index d959eedfeb1a..642c54eac5a6 100644
--- a/security/py-pycrypto/files/patch-setup.py
+++ b/security/py-pycrypto/files/patch-setup.py
@@ -1,14 +1,14 @@
---- ./setup.py.orig 2009-12-13 21:39:29.000000000 +0100
-+++ ./setup.py 2009-12-14 16:48:47.000000000 +0100
-@@ -136,6 +136,7 @@
+--- setup.py.orig 2010-08-08 14:02:23.895825034 +0200
++++ setup.py 2010-08-08 14:04:31.663792751 +0200
+@@ -139,6 +139,7 @@
# especially helps the DES modules.
self.__add_compiler_option("-O3")
self.__add_compiler_option("-fomit-frame-pointer")
+ self.__add_compiler_option("-D_WCHAR_T_DEFINED")
# Don't include debug symbols unless debugging
self.__remove_compiler_option("-g")
- if USE_GCOV:
-@@ -152,7 +153,7 @@
+ # Don't include profiling information (incompatible with -fomit-frame-pointer)
+@@ -157,7 +158,7 @@
self.compiler.include_dirs.insert(0, "src/inc-msvc/")
# Detect libgmp and don't build _fastmath if it is missing.
@@ -17,7 +17,7 @@
if not (self.compiler.find_library_file(lib_dirs, 'gmp')):
print >>sys.stderr, "warning: GMP library not found; Not building Crypto.PublicKey._fastmath."
self.__remove_extensions(["Crypto.PublicKey._fastmath"])
-@@ -259,6 +260,7 @@
+@@ -264,6 +265,7 @@
Extension("Crypto.PublicKey._fastmath",
include_dirs=['src/'],
libraries=['gmp'],