aboutsummaryrefslogtreecommitdiff
path: root/security/py-pycryptodome/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-pycryptodome/Makefile')
-rw-r--r--security/py-pycryptodome/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/security/py-pycryptodome/Makefile b/security/py-pycryptodome/Makefile
index bd3e0b5d56a3..8dce5f756172 100644
--- a/security/py-pycryptodome/Makefile
+++ b/security/py-pycryptodome/Makefile
@@ -1,5 +1,5 @@
-PORTNAME= pycryptodome
-DISTVERSION= 3.19.0
+PORTNAME?= pycryptodome
+DISTVERSION= 3.20.0
CATEGORIES= security python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,14 +12,17 @@ LICENSE= APACHE20 BSD2CLAUSE PD
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENSE.rst
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycryptodome-test-vectors>=0:security/py-pycryptodome-test-vectors@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycryptodome-test-vectors>=0:security/py-pycryptodome-test-vectors@${PY_FLAVOR} \
+ gmp>=0:math/gmp
# Officially: 2.7, 3.5-3.12
USES= cpe python
CPE_VENDOR= python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist pep517
-CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pycrypto
+CONFLICTS_INSTALL?= ${PYTHON_PKGNAMEPREFIX}pycrypto
NAMESPACE?= Crypto