aboutsummaryrefslogtreecommitdiff
path: root/security/py-python-registry/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-python-registry/Makefile')
-rw-r--r--security/py-python-registry/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/security/py-python-registry/Makefile b/security/py-python-registry/Makefile
new file mode 100644
index 000000000000..3d6213b624a1
--- /dev/null
+++ b/security/py-python-registry/Makefile
@@ -0,0 +1,38 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= python-registry
+PORTVERSION= 0.2.5
+CATEGORIES= security devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Read access to Windows Registry files
+
+LICENSE= AL2
+
+USE_GITHUB= yes
+GH_ACCOUNT= williballenthin
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 8ea7e05
+
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|0.2.4.1|${PORTVERSION}|' ${WRKSRC}/Registry/__init__.py
+ ${REINPLACE_CMD} -i '' -e 's|/usr/bin/python|${PYTHON_CMD}|' ${WRKSRC}/samples/*
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${WRKSRC}/documentation/* ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/samples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>