aboutsummaryrefslogtreecommitdiff
path: root/security/py-requests-credssp
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-requests-credssp')
-rw-r--r--security/py-requests-credssp/Makefile22
-rw-r--r--security/py-requests-credssp/distinfo3
-rw-r--r--security/py-requests-credssp/pkg-descr3
3 files changed, 28 insertions, 0 deletions
diff --git a/security/py-requests-credssp/Makefile b/security/py-requests-credssp/Makefile
new file mode 100644
index 000000000000..1a22be432a17
--- /dev/null
+++ b/security/py-requests-credssp/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= requests-credssp
+PORTVERSION= 0.1.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rozhuk.im@gmail.com
+COMMENT= Authentication handler for using CredSSP with Python Requests
+
+LICENSE= ISCL
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.0.0:www/py-requests@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=16.0.0:security/py-openssl@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ntlm-auth>=0:security/py-ntlm-auth@${FLAVOR}
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-requests-credssp/distinfo b/security/py-requests-credssp/distinfo
new file mode 100644
index 000000000000..43d36d92020a
--- /dev/null
+++ b/security/py-requests-credssp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520514244
+SHA256 (requests-credssp-0.1.0.tar.gz) = f2888920b065bc1d3c8c13004fbb0df76fbd6585ee4d951d89c42ef22becee03
+SIZE (requests-credssp-0.1.0.tar.gz) = 14545
diff --git a/security/py-requests-credssp/pkg-descr b/security/py-requests-credssp/pkg-descr
new file mode 100644
index 000000000000..4e5f605fc06c
--- /dev/null
+++ b/security/py-requests-credssp/pkg-descr
@@ -0,0 +1,3 @@
+An authentication handler for using CredSSP with Python Requests.
+
+WWW: https://github.com/jborean93/requests-credssp