aboutsummaryrefslogtreecommitdiff
path: root/security/zeek/files/patch-src_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'security/zeek/files/patch-src_CMakeLists.txt')
-rw-r--r--security/zeek/files/patch-src_CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/security/zeek/files/patch-src_CMakeLists.txt b/security/zeek/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..de12b5954a97
--- /dev/null
+++ b/security/zeek/files/patch-src_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- src/CMakeLists.txt.orig 2021-04-09 11:46:37 UTC
++++ src/CMakeLists.txt
+@@ -344,6 +344,7 @@ set(HH_SRCS
+ )
+
+ if (${COMPILER_ARCHITECTURE} STREQUAL "arm")
++ list(APPEND HH_SRCS ../auxil/highwayhash/highwayhash/hh_neon.cc)
+ set_source_files_properties(${HH_SRCS} PROPERTIES COMPILE_FLAGS
+ -mfloat-abi=hard -march=armv7-a -mfpu=neon)
+ elseif (${COMPILER_ARCHITECTURE} STREQUAL "aarch64")