aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/dirmngr/Makefile3
-rw-r--r--security/fiked/Makefile3
-rw-r--r--security/gnupg/Makefile4
-rw-r--r--security/gnutls-devel/Makefile3
-rw-r--r--security/gnutls/Makefile4
-rw-r--r--security/gsasl/Makefile4
-rw-r--r--security/libgnome-keyring/Makefile4
-rw-r--r--security/libotr/Makefile2
-rw-r--r--security/libssh/Makefile3
-rw-r--r--security/libssh2/Makefile1
-rw-r--r--security/opencdk/Makefile4
-rw-r--r--security/openvas-libnasl/Makefile3
-rw-r--r--security/p5-Crypt-GCrypt/Makefile3
-rw-r--r--security/pidgin-otr/Makefile2
-rw-r--r--security/pinentry/Makefile4
-rw-r--r--security/seccure/Makefile4
-rw-r--r--security/shishi/Makefile4
-rw-r--r--security/vpnc/Makefile4
18 files changed, 33 insertions, 26 deletions
diff --git a/security/dirmngr/Makefile b/security/dirmngr/Makefile
index bb2b27a73ca6..b267b721f165 100644
--- a/security/dirmngr/Makefile
+++ b/security/dirmngr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dirmngr
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= dirmngr
@@ -17,7 +18,7 @@ MAINTAINER= umq@ueo.co.jp
COMMENT= A client for managing and downloading certificate revocation lists
LIB_DEPENDS= assuan.0:${PORTSDIR}/security/libassuan \
- gcrypt.16:${PORTSDIR}/security/libgcrypt \
+ gcrypt.17:${PORTSDIR}/security/libgcrypt \
gpg-error.0:${PORTSDIR}/security/libgpg-error \
ksba.17:${PORTSDIR}/security/libksba \
pth:${PORTSDIR}/devel/pth
diff --git a/security/fiked/Makefile b/security/fiked/Makefile
index 8f29db32194f..996eeb6aca55 100644
--- a/security/fiked/Makefile
+++ b/security/fiked/Makefile
@@ -7,13 +7,14 @@
PORTNAME= fiked
PORTVERSION= 0.0.5
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://mirror.roe.ch/dist/fiked/
MAINTAINER= daniel@roe.ch
COMMENT= A fake IKE PSK+XAUTH daemon based on VPNC
-LIB_DEPENDS= gcrypt.16:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= gcrypt.17:${PORTSDIR}/security/libgcrypt
.if !defined(WITHOUT_LIBNET)
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
.endif
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index 0038b1378e7c..44fd01882786 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnupg
PORTVERSION= 2.0.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gnupg
@@ -19,7 +19,7 @@ COMMENT= The GNU Privacy Guard
BUILD_DEPENDS= libksba>=1.0.7:${PORTSDIR}/security/libksba
LIB_DEPENDS= assuan.0:${PORTSDIR}/security/libassuan \
- gcrypt.16:${PORTSDIR}/security/libgcrypt \
+ gcrypt.17:${PORTSDIR}/security/libgcrypt \
gpg-error:${PORTSDIR}/security/libgpg-error \
ksba.17:${PORTSDIR}/security/libksba \
pth.20:${PORTSDIR}/devel/pth
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
index 869b52a64c49..2343be6cf6a8 100644
--- a/security/gnutls-devel/Makefile
+++ b/security/gnutls-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnutls
PORTVERSION= 2.11.0
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= http://alpha.gnu.org/gnu/gnutls/ \
ftp://ftp.gnutls.org/pub/gnutls/devel/
@@ -15,7 +16,7 @@ PKGNAMESUFFIX= -devel
MAINTAINER= novel@FreeBSD.org
COMMENT= GNU Transport Layer Security library
-LIB_DEPENDS= gcrypt.16:${PORTSDIR}/security/libgcrypt \
+LIB_DEPENDS= gcrypt.17:${PORTSDIR}/security/libgcrypt \
gpg-error.0:${PORTSDIR}/security/libgpg-error
CONFLICTS= gnutls-[0-9]*
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 25c9b899d754..e2f2d002cc1b 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnutls
PORTVERSION= 2.8.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security net
MASTER_SITES= ${MASTER_SITE_GNU} \
${MASTER_SITE_GNUPG}
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= novel@FreeBSD.org
COMMENT= GNU Transport Layer Security library
-LIB_DEPENDS= gcrypt.16:${PORTSDIR}/security/libgcrypt \
+LIB_DEPENDS= gcrypt.17:${PORTSDIR}/security/libgcrypt \
gpg-error.0:${PORTSDIR}/security/libgpg-error
CONFLICTS= gnutls-devel-[0-9]*
diff --git a/security/gsasl/Makefile b/security/gsasl/Makefile
index 9dde280cc4f9..4020d8e56f5b 100644
--- a/security/gsasl/Makefile
+++ b/security/gsasl/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gsasl
PORTVERSION= 1.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,7 +17,7 @@ MAINTAINER= krion@FreeBSD.org
COMMENT= GNU SASL Library
LIB_DEPENDS= idn.16:${PORTSDIR}/dns/libidn \
- gcrypt.16:${PORTSDIR}/security/libgcrypt \
+ gcrypt.17:${PORTSDIR}/security/libgcrypt \
ntlm.0:${PORTSDIR}/security/libntlm
USE_GNOME= gnomehack gnometarget pkgconfig
diff --git a/security/libgnome-keyring/Makefile b/security/libgnome-keyring/Makefile
index 2a2687e2a69e..89c1860cfe0a 100644
--- a/security/libgnome-keyring/Makefile
+++ b/security/libgnome-keyring/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libgnome-keyring
PORTVERSION= 2.30.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security gnome
MASTER_SITES= GNOME
@@ -15,7 +15,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A program that keeps passwords and other secrets
LIB_DEPENDS= tasn1.4:${PORTSDIR}/security/libtasn1 \
- gcrypt.16:${PORTSDIR}/security/libgcrypt
+ gcrypt.17:${PORTSDIR}/security/libgcrypt
USE_BZIP2= yes
USE_GNOME= gnomehack gnomeprefix ltverhack intlhack gconf2
diff --git a/security/libotr/Makefile b/security/libotr/Makefile
index 7401716c7d00..c611a315bff0 100644
--- a/security/libotr/Makefile
+++ b/security/libotr/Makefile
@@ -8,7 +8,7 @@
PORTNAME= libotr
PORTVERSION= 3.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.cypherpunks.ca/otr/ \
http://dougbarton.us/Downloads/
diff --git a/security/libssh/Makefile b/security/libssh/Makefile
index 91a531cb59ad..678646e0a00e 100644
--- a/security/libssh/Makefile
+++ b/security/libssh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libssh
PORTVERSION= 0.4.4
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.libssh.org/files/ \
LOCAL/avl
@@ -28,7 +29,7 @@ USE_LDCONFIG= yes
.include <bsd.port.options.mk>
.if defined(WITH_GCRYPT)
-LIB_DEPENDS+= gcrypt.16:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS+= gcrypt.17:${PORTSDIR}/security/libgcrypt
CMAKE_ARGS+= -DWITH_GCRYPT:BOOL=ON
.else
USE_OPENSSL= yes
diff --git a/security/libssh2/Makefile b/security/libssh2/Makefile
index 30cbaefcabb2..1ee2f9d39f37 100644
--- a/security/libssh2/Makefile
+++ b/security/libssh2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libssh2
PORTVERSION= 1.2.6
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= security devel
MASTER_SITES= http://www.libssh2.org/download/
diff --git a/security/opencdk/Makefile b/security/opencdk/Makefile
index 541e6e9291b2..f97a6a6046b1 100644
--- a/security/opencdk/Makefile
+++ b/security/opencdk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opencdk
PORTVERSION= 0.6.6
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://josefsson.org/gnutls/releases/opencdk/
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= alpha/gnutls/opencdk
MAINTAINER= novel@FreeBSD.org
COMMENT= Open Crypto Development Kit
-LIB_DEPENDS= gcrypt.16:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= gcrypt.17:${PORTSDIR}/security/libgcrypt
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/security/openvas-libnasl/Makefile b/security/openvas-libnasl/Makefile
index 607ff054d6f4..b668fd2dd738 100644
--- a/security/openvas-libnasl/Makefile
+++ b/security/openvas-libnasl/Makefile
@@ -7,13 +7,14 @@
PORTNAME= openvas-libnasl
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://wald.intevation.org/frs/download.php/561/
MAINTAINER= ports@FreeBSD.org
COMMENT= NASL libraries for OpenVAS
-LIB_DEPENDS= gcrypt.16:${PORTSDIR}/security/libgcrypt \
+LIB_DEPENDS= gcrypt.17:${PORTSDIR}/security/libgcrypt \
gnutls.40:${PORTSDIR}/security/gnutls \
gpg-error.0:${PORTSDIR}/security/libgpg-error \
gpgme.18:${PORTSDIR}/security/gpgme \
diff --git a/security/p5-Crypt-GCrypt/Makefile b/security/p5-Crypt-GCrypt/Makefile
index e92470cce4ec..aeba578d7fad 100644
--- a/security/p5-Crypt-GCrypt/Makefile
+++ b/security/p5-Crypt-GCrypt/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Crypt-GCrypt
PORTVERSION= 1.24
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kaoru@kaisei.org
COMMENT= Perl interface to the GNU Cryptographic library
-LIB_DEPENDS= gcrypt.16:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= gcrypt.17:${PORTSDIR}/security/libgcrypt
PERL_CONFIGURE= 5.6.0+
CONFIGURE_ARGS+= GCRYPTLIBPATH=${LOCALBASE}/lib \
diff --git a/security/pidgin-otr/Makefile b/security/pidgin-otr/Makefile
index 94674ac67f8b..06ca83bdd59d 100644
--- a/security/pidgin-otr/Makefile
+++ b/security/pidgin-otr/Makefile
@@ -8,7 +8,7 @@
PORTNAME= otr
PORTVERSION= 3.2.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security net
MASTER_SITES= http://www.cypherpunks.ca/otr/ \
http://dougbarton.us/Downloads/
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index f8049d4601a8..3369f513697e 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pinentry
PORTVERSION= 0.8.0
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= pinentry
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= pinentry
MAINTAINER= makc@FreeBSD.org
COMMENT?= A collection of simple PIN or passphrase entry dialogs
-LIB_DEPENDS= gcrypt.16:${PORTSDIR}/security/libgcrypt \
+LIB_DEPENDS= gcrypt.17:${PORTSDIR}/security/libgcrypt \
ksba.17:${PORTSDIR}/security/libksba
CONFLICTS?= pinentry-[a-z]*-[0.9]*
diff --git a/security/seccure/Makefile b/security/seccure/Makefile
index 2259d0a86830..458d52c537cd 100644
--- a/security/seccure/Makefile
+++ b/security/seccure/Makefile
@@ -7,14 +7,14 @@
PORTNAME= seccure
PORTVERSION= 0.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://point-at-infinity.org/seccure/
MAINTAINER= luke@REMOVE_IT.novum.am.lublin.pl
COMMENT= SECCURE Elliptic Curve Crypto Utility for Reliable Encryption
-LIB_DEPENDS= gcrypt.16:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= gcrypt.17:${PORTSDIR}/security/libgcrypt
MAN1= seccure.1
diff --git a/security/shishi/Makefile b/security/shishi/Makefile
index f196b1aa343c..5289b3d931b5 100644
--- a/security/shishi/Makefile
+++ b/security/shishi/Makefile
@@ -8,7 +8,7 @@
PORTNAME= shishi
PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= GNU
@@ -17,7 +17,7 @@ COMMENT= A free implementation of the Kerberos 5 network security system
LIB_DEPENDS= idn.16:${PORTSDIR}/dns/libidn \
tasn1.4:${PORTSDIR}/security/libtasn1 \
- gcrypt.16:${PORTSDIR}/security/libgcrypt \
+ gcrypt.17:${PORTSDIR}/security/libgcrypt \
gnutls.40:${PORTSDIR}/security/gnutls
USE_AUTOTOOLS= libtool:22
diff --git a/security/vpnc/Makefile b/security/vpnc/Makefile
index d2e3bccfd8f9..1907e17602ca 100644
--- a/security/vpnc/Makefile
+++ b/security/vpnc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vpnc
PORTVERSION= 0.5.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://www.unix-ag.uni-kl.de/~massar/vpnc/ \
CRITICAL
@@ -15,7 +15,7 @@ MASTER_SITES= http://www.unix-ag.uni-kl.de/~massar/vpnc/ \
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Client for Cisco 3000 VPN Concentrator
-LIB_DEPENDS= gcrypt.16:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= gcrypt.17:${PORTSDIR}/security/libgcrypt
USE_GMAKE= yes
USE_PERL5_BUILD=yes