aboutsummaryrefslogtreecommitdiff
path: root/shells/nushell/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/nushell/Makefile')
-rw-r--r--shells/nushell/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/shells/nushell/Makefile b/shells/nushell/Makefile
index be61596d5b7a..0eec6afc5680 100644
--- a/shells/nushell/Makefile
+++ b/shells/nushell/Makefile
@@ -607,6 +607,13 @@ DATAFRAME_DESC= Include the dataframe feature
DATAFRAME_VARS= CARGO_BUILD_ARGS+=--features=dataframe
DATAFRAME_BROKEN= see https://github.com/nushell/nushell/issues/7665
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+LIB_DEPENDS= libatomic.so:lang/gcc${GCC_DEFAULT}
+LDFLAGS= -L/usr/local/lib/gcc${GCC_DEFAULT} -latomic
+.endif
+
.include <bsd.port.pre.mk>
# avoid address space exhaustion in compiler