aboutsummaryrefslogtreecommitdiff
path: root/shells/pear-PHP_Shell/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/pear-PHP_Shell/Makefile')
-rw-r--r--shells/pear-PHP_Shell/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/shells/pear-PHP_Shell/Makefile b/shells/pear-PHP_Shell/Makefile
new file mode 100644
index 000000000000..9c988c3fce66
--- /dev/null
+++ b/shells/pear-PHP_Shell/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: pear-PHP_Shell
+# Date created: 05 August 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PHP_Shell
+PORTVERSION= 0.3.0
+CATEGORIES= shells www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A interactive PHP Shell
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+FILES= ShellTests.php PHP/Shell.php \
+ PHP/Shell/Commands.php PHP/Shell/Extensions.php \
+ PHP/Shell/Options.php \
+ PHP/Shell/Extensions/Autoload.php \
+ PHP/Shell/Extensions/AutoloadDebug.php \
+ PHP/Shell/Extensions/Colour.php \
+ PHP/Shell/Extensions/ExecutionTime.php \
+ PHP/Shell/Extensions/InlineHelp.php \
+ PHP/Shell/Extensions/Prototypes.php \
+ PHP/Shell/Extensions/VerbosePrint.php
+EXAMPLES= php-shell-cmd.php
+SCRIPTSFILES= php-shell-cmd.php php-shell.bat \
+ php-shell.sh
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>