aboutsummaryrefslogtreecommitdiff
path: root/sysutils/accountsservice/files/patch-meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/accountsservice/files/patch-meson.build')
-rw-r--r--sysutils/accountsservice/files/patch-meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/sysutils/accountsservice/files/patch-meson.build b/sysutils/accountsservice/files/patch-meson.build
index 0c44fe80183b..4149f6c07630 100644
--- a/sysutils/accountsservice/files/patch-meson.build
+++ b/sysutils/accountsservice/files/patch-meson.build
@@ -8,3 +8,16 @@
config_h.set_quoted('PATH_WTMP', path_wtmp)
endif
+@@ -159,11 +158,7 @@ polkit_gobject_dep = dependency('polkit-gobject-1')
+ # salt drawn from secure system ressources with at least 128 bits.
+ # (96 bits for sha512crypt, as more is not supported by this method, since
+ # the effectively used maximum is 16 base64-encoded characters)
+-crypt_dep = dependency('libxcrypt', required: false, version: '>= 4')
+-config_h.set('HAVE_CRYPT_GENSALT', crypt_dep.found())
+-if not crypt_dep.found()
+- crypt_dep = cc.find_library('crypt')
+-endif
++crypt_dep = cc.find_library('crypt')
+
+ dbus_dep = dependency('dbus-1')
+ if dbus_dep.version().version_compare('>=1.9.18')