aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cfengine3/files/patch-af
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/cfengine3/files/patch-af')
-rw-r--r--sysutils/cfengine3/files/patch-af13
1 files changed, 13 insertions, 0 deletions
diff --git a/sysutils/cfengine3/files/patch-af b/sysutils/cfengine3/files/patch-af
new file mode 100644
index 000000000000..c7a33e7b209e
--- /dev/null
+++ b/sysutils/cfengine3/files/patch-af
@@ -0,0 +1,13 @@
+Fix the linking so only cfd is linked with pthreads. This keeps cfengine
+from trying to use thread-unsafe resolver functions.
+
+--- src/Makefile.am.orig Fri Aug 10 23:58:47 2001
++++ src/Makefile.am Fri Aug 10 23:59:07 2001
+@@ -95,6 +95,7 @@
+ patches.c
+
+ cfd_LDADD = -L../pub -lpub $(LEXLIB)
++cfd_LDFLAGS = -pthread $(LDFLAGS)
+
+ cfrun_SOURCES = \
+ cfrun.c \