aboutsummaryrefslogtreecommitdiff
path: root/sysutils/chezmoi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/chezmoi/Makefile')
-rw-r--r--sysutils/chezmoi/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/sysutils/chezmoi/Makefile b/sysutils/chezmoi/Makefile
index d5af0809d9da..024ad42dc3cc 100644
--- a/sysutils/chezmoi/Makefile
+++ b/sysutils/chezmoi/Makefile
@@ -2,7 +2,7 @@
PORTNAME= chezmoi
DISTVERSIONPREFIX= v
-DISTVERSION= 2.3.0
+DISTVERSION= 2.4.0
CATEGORIES= sysutils
MAINTAINER= samir@noir.im
@@ -15,7 +15,8 @@ USES= go:modules
USE_GITHUB= yes
GH_ACCOUNT= twpayne
-GH_TUPLE= Masterminds:goutils:v1.1.1:masterminds_goutils/vendor/github.com/Masterminds/goutils \
+GH_TUPLE= FiloSottile:age:v1.0.0:filosottile_age/vendor/filippo.io/age \
+ Masterminds:goutils:v1.1.1:masterminds_goutils/vendor/github.com/Masterminds/goutils \
Masterminds:semver:v3.1.1:masterminds_semver_v3/vendor/github.com/Masterminds/semver/v3 \
Masterminds:sprig:v3.2.2:masterminds_sprig_v3/vendor/github.com/Masterminds/sprig/v3 \
Microsoft:go-winio:v0.5.0:microsoft_go_winio/vendor/github.com/Microsoft/go-winio \
@@ -41,22 +42,22 @@ GH_TUPLE= Masterminds:goutils:v1.1.1:masterminds_goutils/vendor/github.com/Maste
go-git:gcfg:v1.5.0:go_git_gcfg/vendor/github.com/go-git/gcfg \
go-git:go-billy:v5.3.1:go_git_go_billy_v5/vendor/github.com/go-git/go-billy/v5 \
go-git:go-git:v5.4.2:go_git_go_git_v5/vendor/github.com/go-git/go-git/v5 \
- go-ini:ini:v1.62.0:go_ini_ini/vendor/gopkg.in/ini.v1 \
+ go-ini:ini:v1.63.0:go_ini_ini/vendor/gopkg.in/ini.v1 \
go-warnings:warnings:v0.1.2:go_warnings_warnings/vendor/gopkg.in/warnings.v0 \
go-yaml:yaml:496545a6307b:go_yaml_yaml_1/vendor/gopkg.in/yaml.v3 \
go-yaml:yaml:v2.4.0:go_yaml_yaml/vendor/gopkg.in/yaml.v2 \
- godbus:dbus:v5.0.4:godbus_dbus_v5/vendor/github.com/godbus/dbus/v5 \
+ godbus:dbus:v5.0.5:godbus_dbus_v5/vendor/github.com/godbus/dbus/v5 \
golang:appengine:v1.6.7:golang_appengine/vendor/google.golang.org/appengine \
golang:crypto:32db794688a5:golang_crypto/vendor/golang.org/x/crypto \
- golang:net:e898025ed96a:golang_net/vendor/golang.org/x/net \
+ golang:net:a5e095526f91:golang_net/vendor/golang.org/x/net \
golang:oauth2:2bc19b11175f:golang_oauth2/vendor/golang.org/x/oauth2 \
golang:protobuf:v1.5.2:golang_protobuf/vendor/github.com/golang/protobuf \
- golang:sys:63515b42dcdf:golang_sys/vendor/golang.org/x/sys \
+ golang:sys:528a39cd75f3:golang_sys/vendor/golang.org/x/sys \
golang:term:6886f2dfbf5b:golang_term/vendor/golang.org/x/term \
golang:text:v0.3.7:golang_text/vendor/golang.org/x/text \
- google:go-github:v38.1.0:google_go_github_v38/vendor/github.com/google/go-github/v38 \
+ google:go-github:v39.0.0:google_go_github_v39/vendor/github.com/google/go-github/v39 \
google:go-querystring:v1.1.0:google_go_querystring/vendor/github.com/google/go-querystring \
- google:gops:v0.3.19:google_gops/vendor/github.com/google/gops \
+ google:gops:v0.3.20:google_gops/vendor/github.com/google/gops \
google:renameio:v1.0.1:google_renameio/vendor/github.com/google/renameio \
google:uuid:v1.3.0:google_uuid/vendor/github.com/google/uuid \
gopherjs:gopherjs:fce0ec30dd00:gopherjs_gopherjs/vendor/github.com/gopherjs/gopherjs \
@@ -69,7 +70,7 @@ GH_TUPLE= Masterminds:goutils:v1.1.1:masterminds_goutils/vendor/github.com/Maste
kevinburke:ssh_config:v1.1.0:kevinburke_ssh_config/vendor/github.com/kevinburke/ssh_config \
lucasb-eyer:go-colorful:v1.2.0:lucasb_eyer_go_colorful/vendor/github.com/lucasb-eyer/go-colorful \
magiconair:properties:v1.8.5:magiconair_properties/vendor/github.com/magiconair/properties \
- mattn:go-isatty:v0.0.13:mattn_go_isatty/vendor/github.com/mattn/go-isatty \
+ mattn:go-isatty:v0.0.14:mattn_go_isatty/vendor/github.com/mattn/go-isatty \
mattn:go-runewidth:v0.0.13:mattn_go_runewidth/vendor/github.com/mattn/go-runewidth \
microcosm-cc:bluemonday:v1.0.15:microcosm_cc_bluemonday/vendor/github.com/microcosm-cc/bluemonday \
mitchellh:copystructure:v1.2.0:mitchellh_copystructure/vendor/github.com/mitchellh/copystructure \
@@ -80,14 +81,14 @@ GH_TUPLE= Masterminds:goutils:v1.1.1:masterminds_goutils/vendor/github.com/Maste
muesli:reflow:v0.3.0:muesli_reflow/vendor/github.com/muesli/reflow \
muesli:termenv:v0.9.0:muesli_termenv/vendor/github.com/muesli/termenv \
olekukonko:tablewriter:v0.0.5:olekukonko_tablewriter/vendor/github.com/olekukonko/tablewriter \
- pelletier:go-toml:v1.9.3:pelletier_go_toml/vendor/github.com/pelletier/go-toml \
+ pelletier:go-toml:v1.9.4:pelletier_go_toml/vendor/github.com/pelletier/go-toml \
pkg:diff:20ebb0f2a09e:pkg_diff/vendor/github.com/pkg/diff \
pkg:errors:v0.9.1:pkg_errors/vendor/github.com/pkg/errors \
pmezard:go-difflib:v1.0.0:pmezard_go_difflib/vendor/github.com/pmezard/go-difflib \
protocolbuffers:protobuf-go:v1.27.1:protocolbuffers_protobuf_go/vendor/google.golang.org/protobuf \
rivo:uniseg:v0.2.0:rivo_uniseg/vendor/github.com/rivo/uniseg \
rogpeppe:go-internal:v1.8.0:rogpeppe_go_internal/vendor/github.com/rogpeppe/go-internal \
- rs:zerolog:v1.24.0:rs_zerolog/vendor/github.com/rs/zerolog \
+ rs:zerolog:v1.25.0:rs_zerolog/vendor/github.com/rs/zerolog \
sergi:go-diff:v1.1.0:sergi_go_diff/vendor/github.com/sergi/go-diff \
shopspring:decimal:v1.2.0:shopspring_decimal/vendor/github.com/shopspring/decimal \
smartystreets:assertions:v1.2.0:smartystreets_assertions/vendor/github.com/smartystreets/assertions \
@@ -101,7 +102,7 @@ GH_TUPLE= Masterminds:goutils:v1.1.1:masterminds_goutils/vendor/github.com/Maste
stretchr:testify:v1.7.0:stretchr_testify/vendor/github.com/stretchr/testify \
subosito:gotenv:v1.2.0:subosito_gotenv/vendor/github.com/subosito/gotenv \
twpayne:go-shell:v0.3.0:twpayne_go_shell/vendor/github.com/twpayne/go-shell \
- twpayne:go-vfs:v3.0.0:twpayne_go_vfs_v3/vendor/github.com/twpayne/go-vfs/v3 \
+ twpayne:go-vfs:v4.0.0:twpayne_go_vfs_v4/vendor/github.com/twpayne/go-vfs/v4 \
twpayne:go-xdg:v6.0.0:twpayne_go_xdg_v6/vendor/github.com/twpayne/go-xdg/v6 \
uber-go:atomic:v1.9.0:uber_go_atomic/vendor/go.uber.org/atomic \
uber-go:multierr:v1.7.0:uber_go_multierr/vendor/go.uber.org/multierr \