aboutsummaryrefslogtreecommitdiff
path: root/sysutils/consolekit2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/consolekit2/Makefile')
-rw-r--r--sysutils/consolekit2/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/sysutils/consolekit2/Makefile b/sysutils/consolekit2/Makefile
index e9895cc1d7fe..57f2a4af2d0b 100644
--- a/sysutils/consolekit2/Makefile
+++ b/sysutils/consolekit2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= consolekit
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= https://github.com/ConsoleKit2/ConsoleKit2/releases/download/${PORTVERSION}/
PKGNAMESUFFIX= 2
@@ -39,4 +40,11 @@ CONFIGURE_ARGS= --with-pid-file=/var/run/${PORTNAME}.pid \
--without-systemdsystemunitdir
INSTALL_TARGET= install-strip
+post-install:
+.for script in ck-system-hibernate ck-system-hybridsleep \
+ ck-system-restart ck-system-stop ck-system-suspend
+ cd ${STAGEDIR}${PREFIX}/lib/ConsoleKit/scripts && \
+ ${MV} ${script} ${script}.sample
+.endfor
+
.include <bsd.port.mk>