aboutsummaryrefslogtreecommitdiff
path: root/sysutils/devd-mount/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/devd-mount/Makefile')
-rw-r--r--sysutils/devd-mount/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/devd-mount/Makefile b/sysutils/devd-mount/Makefile
new file mode 100644
index 000000000000..fdf5d02ae5c0
--- /dev/null
+++ b/sysutils/devd-mount/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= devd-mount
+DISTVERSION= 0.1.0-1
+DISTVERSIONSUFFIX= -gd153f96
+CATEGORIES= sysutils
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Automount tool utilizing devd notifications
+WWW= https://github.com/outpaddling/devd-mount
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= outpaddling
+
+NO_BUILD= yes
+
+PLIST_FILES= sbin/devd-mount \
+ etc/devd/devd-mount.conf \
+ "@sample etc/devd-mount.conf.sample" \
+ man/man8/devd-mount.8.gz
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/devd-mount ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/devd.conf \
+ ${STAGEDIR}${PREFIX}/etc/devd/devd-mount.conf
+ ${INSTALL_DATA} ${WRKSRC}/devd-mount.conf \
+ ${STAGEDIR}${PREFIX}/etc/devd-mount.conf.sample
+ ${INSTALL_MAN} ${WRKSRC}/Man/devd-mount.8 \
+ ${STAGEDIR}${MANPREFIX}/man/man8
+
+.include <bsd.port.mk>