aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gsmartcontrol
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gsmartcontrol')
-rw-r--r--sysutils/gsmartcontrol/Makefile35
-rw-r--r--sysutils/gsmartcontrol/distinfo3
-rw-r--r--sysutils/gsmartcontrol/files/extra-Makefile.in33
-rw-r--r--sysutils/gsmartcontrol/files/patch-data_Makefile.in11
-rw-r--r--sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in8
-rw-r--r--sysutils/gsmartcontrol/pkg-descr8
-rw-r--r--sysutils/gsmartcontrol/pkg-plist40
7 files changed, 138 insertions, 0 deletions
diff --git a/sysutils/gsmartcontrol/Makefile b/sysutils/gsmartcontrol/Makefile
new file mode 100644
index 000000000000..9c320b02d319
--- /dev/null
+++ b/sysutils/gsmartcontrol/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gsmartcontrol
+# Date created: 2009-03-25
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsmartcontrol
+PORTVERSION= 0.8.4
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_BERLIOS}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= Graphical user interface for smartmontools
+
+LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ pcre:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= ${LOCALBASE}/sbin/smartctl:${PORTSDIR}/sysutils/smartmontools
+
+USE_AUTOTOOLS= libtool:15
+USE_BZIP2= yes
+USE_GNOME= pkgconfig
+INSTALLS_ICONS= yes
+
+MAN1= gsmartcontrol.1
+
+CONFIGURE_ARGS= --disable-libglade
+
+post-patch:
+.if defined(NOPORTDOCS)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/gsmartcontrol/distinfo b/sysutils/gsmartcontrol/distinfo
new file mode 100644
index 000000000000..d1d628897d04
--- /dev/null
+++ b/sysutils/gsmartcontrol/distinfo
@@ -0,0 +1,3 @@
+MD5 (gsmartcontrol-0.8.4.tar.bz2) = 90c8bbc95726a0c64201f9e51a5abbdd
+SHA256 (gsmartcontrol-0.8.4.tar.bz2) = cbd3583c365bd1f5bb87976341c31a5d6a447e2d837660e2c00828cf2f27b8ee
+SIZE (gsmartcontrol-0.8.4.tar.bz2) = 625264
diff --git a/sysutils/gsmartcontrol/files/extra-Makefile.in b/sysutils/gsmartcontrol/files/extra-Makefile.in
new file mode 100644
index 000000000000..57b6a55ebb42
--- /dev/null
+++ b/sysutils/gsmartcontrol/files/extra-Makefile.in
@@ -0,0 +1,33 @@
+--- ./Makefile.in.orig 2009-03-23 18:59:37.000000000 +0100
++++ Makefile.in 2009-03-26 17:34:55.000000000 +0100
+@@ -328,14 +328,6 @@
+ compilation_flags: $(top_builddir)/config.status $(srcdir)/compilation_flags.in
+ cd $(top_builddir) && $(SHELL) ./config.status $@
+ install-dist_docDATA: $(dist_doc_DATA)
+- @$(NORMAL_INSTALL)
+- test -z "$(docdir)" || $(MKDIR_P) "$(DESTDIR)$(docdir)"
+- @list='$(dist_doc_DATA)'; for p in $$list; do \
+- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- f=$(am__strip_dir) \
+- echo " $(dist_docDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(docdir)/$$f'"; \
+- $(dist_docDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
+- done
+
+ uninstall-dist_docDATA:
+ @$(NORMAL_UNINSTALL)
+@@ -345,15 +337,6 @@
+ rm -f "$(DESTDIR)$(docdir)/$$f"; \
+ done
+ install-nobase_dist_docDATA: $(nobase_dist_doc_DATA)
+- @$(NORMAL_INSTALL)
+- test -z "$(docdir)" || $(MKDIR_P) "$(DESTDIR)$(docdir)"
+- @$(am__vpath_adj_setup) \
+- list='$(nobase_dist_doc_DATA)'; for p in $$list; do \
+- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- $(am__vpath_adj) \
+- echo " $(nobase_dist_docDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(docdir)/$$f'"; \
+- $(nobase_dist_docDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
+- done
+
+ uninstall-nobase_dist_docDATA:
+ @$(NORMAL_UNINSTALL)
diff --git a/sysutils/gsmartcontrol/files/patch-data_Makefile.in b/sysutils/gsmartcontrol/files/patch-data_Makefile.in
new file mode 100644
index 000000000000..a4e3ffa4b66b
--- /dev/null
+++ b/sysutils/gsmartcontrol/files/patch-data_Makefile.in
@@ -0,0 +1,11 @@
+--- ./data/Makefile.in.orig 2009-03-26 11:27:18.000000000 +0100
++++ data/Makefile.in 2009-03-26 11:27:35.000000000 +0100
+@@ -686,7 +686,7 @@
+ uninstall-extra-mans:
+ cd $(DESTDIR)$(mandir)/man1 && rm -f gsmartcontrol-root.1
+
+-install-data-hook: install-extra-mans update-icon-cache
++install-data-hook: update-icon-cache
+ uninstall-hook: uninstall-extra-mans update-icon-cache
+
+ update-icon-cache:
diff --git a/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in b/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in
new file mode 100644
index 000000000000..dc30ce42614a
--- /dev/null
+++ b/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in
@@ -0,0 +1,8 @@
+--- ./data/gsmartcontrol-root.in.orig 2009-03-26 18:58:31.000000000 +0100
++++ data/gsmartcontrol-root.in 2009-03-26 18:58:44.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ ############################################################################
+ # Copyright:
+ # (C) 2008 Alexander Shaduri <ashaduri 'at' gmail.com>
diff --git a/sysutils/gsmartcontrol/pkg-descr b/sysutils/gsmartcontrol/pkg-descr
new file mode 100644
index 000000000000..239b3928e835
--- /dev/null
+++ b/sysutils/gsmartcontrol/pkg-descr
@@ -0,0 +1,8 @@
+GSmartControl is a graphical user interface for smartctl (from
+sysutils/smartmontools port), which is a tool for querying and
+controlling SMART (Self-Monitoring, Analysis, and Reporting
+Technology) data on modern hard disk drives. It allows you to
+inspect the drive's SMART data to determine its health, as well
+as run various tests on it.
+
+WWW: http://gsmartcontrol.berlios.de
diff --git a/sysutils/gsmartcontrol/pkg-plist b/sysutils/gsmartcontrol/pkg-plist
new file mode 100644
index 000000000000..a8462651f3ab
--- /dev/null
+++ b/sysutils/gsmartcontrol/pkg-plist
@@ -0,0 +1,40 @@
+bin/gsmartcontrol
+bin/gsmartcontrol-root
+share/applications/gsmartcontrol.desktop
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE_boost_1_0.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE_bsd-ucb.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE_gpl2.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE_gpl3.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE_gsmartcontrol.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE_hz.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE_pcrecpp.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE_whatever.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE_zlib.txt
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/contrib/cron-based_noadmin/README
+%%PORTDOCS%%%%DOCSDIR%%/contrib/cron-based_noadmin/cron_gather_smart.sh
+%%PORTDOCS%%%%DOCSDIR%%/contrib/cron-based_noadmin/crontab.example
+%%PORTDOCS%%%%DOCSDIR%%/contrib/cron-based_noadmin/smartctl_subst.sh
+%%DATADIR%%/icon_cddvd.png
+%%DATADIR%%/icon_hdd.png
+share/icons/hicolor/128x128/apps/gsmartcontrol.png
+share/icons/hicolor/16x16/apps/gsmartcontrol.png
+share/icons/hicolor/22x22/apps/gsmartcontrol.png
+share/icons/hicolor/24x24/apps/gsmartcontrol.png
+share/icons/hicolor/256x256/apps/gsmartcontrol.png
+share/icons/hicolor/32x32/apps/gsmartcontrol.png
+share/icons/hicolor/48x48/apps/gsmartcontrol.png
+share/icons/hicolor/64x64/apps/gsmartcontrol.png
+share/pixmaps/gsmartcontrol.png
+share/pixmaps/gsmartcontrol.xpm
+@dirrm share/icons/hicolor/256x256/apps
+@dirrm share/icons/hicolor/256x256
+@dirrm share/icons
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/contrib/cron-based_noadmin
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/contrib
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications