aboutsummaryrefslogtreecommitdiff
path: root/sysutils/istio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/istio/Makefile')
-rw-r--r--sysutils/istio/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/sysutils/istio/Makefile b/sysutils/istio/Makefile
index 8a5a969c40d3..7a9cc3965695 100644
--- a/sysutils/istio/Makefile
+++ b/sysutils/istio/Makefile
@@ -5,13 +5,14 @@ PORTNAME= istio
PORTVERSION= 1.0.6
CATEGORIES= sysutils
+PATCH_SITES= https://github.com/go4org/go4/commit/
+PATCHFILES= e4fd39d.patch:-p1 # https://github.com/go4org/go4/issues/43
+
MAINTAINER= danilo@FreeBSD.org
COMMENT= Open platform to connect, manage, and secure microservices
LICENSE= APACHE20
-BROKEN= fails to build
-
RUN_DEPENDS= kubectl:sysutils/kubectl
USES= go
@@ -23,6 +24,8 @@ GO_TARGET= ${GO_PKGNAME}/istioctl/cmd/istioctl
GO_BUILDFLAGS= -ldflags="-X istio.io/istio/pkg/version.buildVersion=${PORTVERSION} \
-X istio.io/istio/pkg/version.buildDockerHub=docker.io/istio"
+PATCH_WRKSRC= ${WRKSRC}/vendor/go4.org
+
post-install:
.for data in consul gcp kubernetes
(cd ${WRKSRC}/install \