aboutsummaryrefslogtreecommitdiff
path: root/sysutils/logserial/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/logserial/Makefile')
-rw-r--r--sysutils/logserial/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/sysutils/logserial/Makefile b/sysutils/logserial/Makefile
new file mode 100644
index 000000000000..e9e0466c1b14
--- /dev/null
+++ b/sysutils/logserial/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: logserial
+# Date created: 25 November 2005
+# Whom: nastya
+#
+# $FreeBSD$
+#
+
+PORTNAME= logserial
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.rsu.ru/pub/sysutils/unix/
+
+MAINTAINER= nastya@rsu.ru
+COMMENT= Daemon logging data from serial port
+
+USE_RC_SUBR= yes
+
+MAN8= logserial.8
+MANCOMPRESSED= yes
+
+PLIST_FILES= bin/logserial \
+ etc/rc.d/logserial.sh \
+
+post-patch:
+ @${REINPLACE_CMD} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${WRKSRC}/logserial.sh
+
+.include <bsd.port.mk>