aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mcfly/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/mcfly/Makefile')
-rw-r--r--sysutils/mcfly/Makefile213
1 files changed, 131 insertions, 82 deletions
diff --git a/sysutils/mcfly/Makefile b/sysutils/mcfly/Makefile
index 9f5583093ed2..7d58ca40429a 100644
--- a/sysutils/mcfly/Makefile
+++ b/sysutils/mcfly/Makefile
@@ -1,7 +1,6 @@
PORTNAME= mcfly
DISTVERSIONPREFIX= v
-DISTVERSION= 0.8.4
-PORTREVISION= 3
+DISTVERSION= 0.8.5
CATEGORIES= sysutils
MAINTAINER= yuri@FreeBSD.org
@@ -17,100 +16,128 @@ USE_GITHUB= yes
GH_ACCOUNT= cantino
CARGO_CRATES= adler32-1.2.0 \
- ahash-0.8.6 \
- aho-corasick-1.1.2 \
- allocator-api2-0.2.16 \
+ ahash-0.8.11 \
+ aho-corasick-1.1.3 \
+ allocator-api2-0.2.18 \
android-tzdata-0.1.1 \
android_system_properties-0.1.5 \
- anstream-0.6.4 \
- anstyle-1.0.4 \
- anstyle-parse-0.2.2 \
- anstyle-query-1.0.0 \
- anstyle-wincon-3.0.1 \
- autocfg-1.1.0 \
+ anstream-0.6.14 \
+ anstyle-1.0.7 \
+ anstyle-parse-0.2.4 \
+ anstyle-query-1.0.3 \
+ anstyle-wincon-3.0.3 \
+ async-trait-0.1.80 \
+ autocfg-1.3.0 \
autopilot-0.4.0 \
+ base64-0.21.7 \
bitflags-1.3.2 \
- bitflags-2.4.1 \
+ bitflags-2.5.0 \
block-0.1.6 \
- bumpalo-3.14.0 \
+ block-buffer-0.10.4 \
+ bumpalo-3.16.0 \
byteorder-1.5.0 \
- cc-1.0.83 \
+ cc-1.0.97 \
cfg-if-1.0.0 \
- chrono-0.4.31 \
+ chrono-0.4.38 \
chrono-systemd-time-0.3.0 \
- clap-4.4.10 \
- clap_builder-4.4.9 \
- clap_derive-4.4.7 \
- clap_lex-0.6.0 \
+ clap-4.5.4 \
+ clap_builder-4.5.2 \
+ clap_derive-4.5.4 \
+ clap_lex-0.7.0 \
cocoa-0.20.2 \
color_quant-1.1.0 \
- colorchoice-1.0.0 \
+ colorchoice-1.0.1 \
+ config-0.14.0 \
+ const-random-0.1.18 \
+ const-random-macro-0.1.16 \
+ convert_case-0.6.0 \
core-foundation-0.7.0 \
core-foundation-sys-0.7.0 \
core-foundation-sys-0.8.6 \
core-graphics-0.19.2 \
- crc32fast-1.3.2 \
- crossbeam-deque-0.8.3 \
- crossbeam-epoch-0.9.15 \
- crossbeam-utils-0.8.16 \
- crossterm-0.26.1 \
+ cpufeatures-0.2.12 \
+ crc32fast-1.4.0 \
+ crossbeam-deque-0.8.5 \
+ crossbeam-epoch-0.9.18 \
+ crossbeam-utils-0.8.19 \
+ crossterm-0.27.0 \
crossterm_winapi-0.9.1 \
+ crunchy-0.2.2 \
+ crypto-common-0.1.6 \
csv-1.3.0 \
csv-core-0.1.11 \
deflate-0.7.20 \
+ digest-0.10.7 \
directories-next-2.0.0 \
- dirs-4.0.0 \
- dirs-sys-0.3.7 \
+ dirs-5.0.1 \
+ dirs-sys-0.4.1 \
dirs-sys-next-0.1.2 \
- either-1.9.0 \
- fallible-iterator-0.2.0 \
+ dlv-list-0.5.2 \
+ either-1.11.0 \
+ equivalent-1.0.1 \
+ fallible-iterator-0.3.0 \
fallible-streaming-iterator-0.1.9 \
filedescriptor-0.8.2 \
foreign-types-0.3.2 \
foreign-types-shared-0.1.1 \
+ generic-array-0.14.7 \
getrandom-0.1.16 \
- getrandom-0.2.11 \
+ getrandom-0.2.15 \
gif-0.10.3 \
- hashbrown-0.14.3 \
- hashlink-0.8.4 \
- heck-0.4.1 \
+ hashbrown-0.13.2 \
+ hashbrown-0.14.5 \
+ hashlink-0.9.0 \
+ heck-0.5.0 \
humantime-2.1.0 \
- iana-time-zone-0.1.58 \
+ iana-time-zone-0.1.60 \
iana-time-zone-haiku-0.1.2 \
image-0.22.5 \
+ indexmap-2.2.6 \
inflate-0.4.5 \
- itertools-0.10.5 \
- itoa-1.0.9 \
+ is_terminal_polyfill-1.70.0 \
+ itertools-0.12.1 \
+ itoa-1.0.11 \
jpeg-decoder-0.1.22 \
- js-sys-0.3.66 \
- libc-0.2.150 \
- libredox-0.0.1 \
- libsqlite3-sys-0.25.2 \
- lock_api-0.4.11 \
- log-0.4.20 \
+ js-sys-0.3.69 \
+ json5-0.4.1 \
+ lazy_static-1.4.0 \
+ libc-0.2.154 \
+ libredox-0.1.3 \
+ libsqlite3-sys-0.28.0 \
+ linked-hash-map-0.5.6 \
+ lock_api-0.4.12 \
+ log-0.4.21 \
lzw-0.10.0 \
malloc_buf-0.0.6 \
- memchr-2.6.4 \
- memoffset-0.9.0 \
- mio-0.8.9 \
+ memchr-2.7.2 \
+ minimal-lexical-0.2.1 \
+ mio-0.8.11 \
+ nom-7.1.3 \
num-derive-0.2.5 \
- num-integer-0.1.45 \
- num-iter-0.1.43 \
+ num-integer-0.1.46 \
+ num-iter-0.1.45 \
num-rational-0.2.4 \
- num-traits-0.2.17 \
+ num-traits-0.2.19 \
objc-0.2.7 \
- once_cell-1.18.0 \
- parking_lot-0.12.1 \
- parking_lot_core-0.9.9 \
+ once_cell-1.19.0 \
+ option-ext-0.2.0 \
+ ordered-multimap-0.6.0 \
+ parking_lot-0.12.2 \
+ parking_lot_core-0.9.10 \
path-absolutize-3.1.1 \
path-dedot-3.1.1 \
- pkg-config-0.3.27 \
+ pathdiff-0.2.1 \
+ pest-2.7.10 \
+ pest_derive-2.7.10 \
+ pest_generator-2.7.10 \
+ pest_meta-2.7.10 \
+ pkg-config-0.3.30 \
png-0.15.3 \
ppv-lite86-0.2.17 \
proc-macro2-0.4.30 \
- proc-macro2-1.0.70 \
+ proc-macro2-1.0.82 \
quote-0.6.13 \
- quote-1.0.33 \
+ quote-1.0.36 \
rand-0.7.3 \
rand-0.8.5 \
rand_chacha-0.2.2 \
@@ -118,60 +145,82 @@ CARGO_CRATES= adler32-1.2.0 \
rand_core-0.5.1 \
rand_core-0.6.4 \
rand_hc-0.2.0 \
- rayon-1.8.0 \
- rayon-core-1.12.0 \
- redox_syscall-0.4.1 \
- redox_users-0.4.4 \
- regex-1.10.2 \
- regex-automata-0.4.3 \
- regex-syntax-0.8.2 \
- rusqlite-0.28.0 \
- ryu-1.0.15 \
+ rayon-1.10.0 \
+ rayon-core-1.12.1 \
+ redox_syscall-0.5.1 \
+ redox_users-0.4.5 \
+ regex-1.10.4 \
+ regex-automata-0.4.6 \
+ regex-syntax-0.8.3 \
+ ron-0.8.1 \
+ rusqlite-0.31.0 \
+ rust-ini-0.19.0 \
+ ryu-1.0.18 \
scoped_threadpool-0.1.9 \
scopeguard-1.2.0 \
- serde-1.0.193 \
- serde_derive-1.0.193 \
- serde_json-1.0.108 \
- shellexpand-2.1.2 \
+ serde-1.0.201 \
+ serde_derive-1.0.201 \
+ serde_json-1.0.117 \
+ serde_spanned-0.6.5 \
+ sha2-0.10.8 \
+ shellexpand-3.1.0 \
signal-hook-0.3.17 \
signal-hook-mio-0.2.3 \
- signal-hook-registry-1.4.1 \
- smallvec-1.11.2 \
- strsim-0.10.0 \
+ signal-hook-registry-1.4.2 \
+ smallvec-1.13.2 \
+ strsim-0.11.1 \
syn-0.15.44 \
- syn-2.0.39 \
- thiserror-1.0.50 \
- thiserror-impl-1.0.50 \
+ syn-2.0.63 \
+ thiserror-1.0.60 \
+ thiserror-impl-1.0.60 \
tiff-0.3.1 \
+ tiny-keccak-2.0.2 \
+ toml-0.8.12 \
+ toml_datetime-0.6.5 \
+ toml_edit-0.22.12 \
+ typenum-1.17.0 \
+ ucd-trie-0.1.6 \
unicode-ident-1.0.12 \
- unicode-segmentation-1.10.1 \
+ unicode-segmentation-1.11.0 \
unicode-xid-0.1.0 \
utf8parse-0.2.1 \
vcpkg-0.2.15 \
version_check-0.9.4 \
wasi-0.9.0+wasi-snapshot-preview1 \
wasi-0.11.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.89 \
- wasm-bindgen-backend-0.2.89 \
- wasm-bindgen-macro-0.2.89 \
- wasm-bindgen-macro-support-0.2.89 \
- wasm-bindgen-shared-0.2.89 \
+ wasm-bindgen-0.2.92 \
+ wasm-bindgen-backend-0.2.92 \
+ wasm-bindgen-macro-0.2.92 \
+ wasm-bindgen-macro-support-0.2.92 \
+ wasm-bindgen-shared-0.2.92 \
winapi-0.3.9 \
winapi-i686-pc-windows-gnu-0.4.0 \
winapi-x86_64-pc-windows-gnu-0.4.0 \
- windows-core-0.51.1 \
+ windows-core-0.52.0 \
windows-sys-0.48.0 \
+ windows-sys-0.52.0 \
windows-targets-0.48.5 \
+ windows-targets-0.52.5 \
windows_aarch64_gnullvm-0.48.5 \
+ windows_aarch64_gnullvm-0.52.5 \
windows_aarch64_msvc-0.48.5 \
+ windows_aarch64_msvc-0.52.5 \
windows_i686_gnu-0.48.5 \
+ windows_i686_gnu-0.52.5 \
+ windows_i686_gnullvm-0.52.5 \
windows_i686_msvc-0.48.5 \
+ windows_i686_msvc-0.52.5 \
windows_x86_64_gnu-0.48.5 \
+ windows_x86_64_gnu-0.52.5 \
windows_x86_64_gnullvm-0.48.5 \
+ windows_x86_64_gnullvm-0.52.5 \
windows_x86_64_msvc-0.48.5 \
+ windows_x86_64_msvc-0.52.5 \
+ winnow-0.6.8 \
x11-2.21.0 \
- zerocopy-0.7.28 \
- zerocopy-derive-0.7.28
+ yaml-rust-0.4.5 \
+ zerocopy-0.7.34 \
+ zerocopy-derive-0.7.34
PLIST_FILES= bin/${PORTNAME} \
etc/bash_completion.d/${PORTNAME}.bash \
share/fish/vendor_completions.d/${PORTNAME}.fish \