aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mtm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/mtm/Makefile')
-rw-r--r--sysutils/mtm/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/sysutils/mtm/Makefile b/sysutils/mtm/Makefile
index d26296fee426..ceabfdf3d2cd 100644
--- a/sysutils/mtm/Makefile
+++ b/sysutils/mtm/Makefile
@@ -1,6 +1,5 @@
PORTNAME= mtm
-DISTVERSION= 1.2.0
-PORTREVISION= 1
+DISTVERSION= 1.2.1
CATEGORIES= sysutils
MAINTAINER= 0mp@FreeBSD.org
@@ -10,18 +9,21 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/README.rst
# NB: ncurses 6.1 is required.
-USES= localbase:ldflags
+USES= localbase
USE_CSTD= gnu99
USE_GITHUB= yes
GH_ACCOUNT= deadpixi
-PLIST_FILES= bin/mtm \
- share/man/man1/mtm.1.gz
+MAKE_ENV= DESTDIR="${DESTDIR}${PREFIX}"
-CFLAGS+= -I${NCURSESINC}
-LDFLAGS+= -L${NCURSESLIB} -ltinfow
+CFLAGS+= -I${NCURSESINC} ${CPPFLAGS}
+LIBS+= -L${NCURSESLIB} -ltinfow -lutil
+BINARY_ALIAS= strip=true
+
+PLIST_FILES= bin/mtm \
+ share/man/man1/mtm.1.gz
PORTDATA= mtm.ti
do-install:
@@ -34,10 +36,13 @@ do-install:
.include <bsd.port.options.mk>
+.if make(makesum) || make(fetch) && "${NO_CHECKSUM}" == yes
+.else
.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1300079
USES+= ncurses:base
.else
USES+= ncurses:port
.endif
+.endif
.include <bsd.port.mk>