aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nvclock/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/nvclock/Makefile')
-rw-r--r--sysutils/nvclock/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/sysutils/nvclock/Makefile b/sysutils/nvclock/Makefile
index 97001e61b9b3..ea0e2b805b40 100644
--- a/sysutils/nvclock/Makefile
+++ b/sysutils/nvclock/Makefile
@@ -6,18 +6,16 @@
#
PORTNAME= nvclock
-PORTVERSION= 0.7
-PORTREVISION= 6
+DISTVERSION= 0.8b2
CATEGORIES= sysutils
MASTER_SITES= http://www.linuxhardware.org/nvclock/ \
http://www.kerneled.com/freebsd/ports/
-DISTNAME= nvclock${PORTVERSION}
+DISTNAME= nvclock${DISTVERSION}
MAINTAINER= sbahra@gwu.edu
COMMENT= The nVidia graphic card status and overclocking tool
USE_GMAKE= yes
-USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig
@@ -29,6 +27,10 @@ USE_GNOME+= gtk20
PLIST_SUB+= GTK=""
.endif
+MAN1= nvclock.1
+
+PORTDOCS= ABOUT AUTHORS ChangeLog FAQ README
+
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "************************************************"
@@ -42,4 +44,15 @@ post-patch:
@${REINPLACE_CMD} -e 's|"CFLAGS="|"CFLAGS+="|g' ${WRKSRC}/${i}
.endfor
+do-install:
+ @${GMAKE} -C ${WRKSRC}/src install
+ @${GMAKE} -C ${WRKSRC} install-man
+.if !defined(WITHOUT_GUI)
+ @${GMAKE} -C ${WRKSRC}/src/gtk install
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${GMAKE} -C ${WRKSRC} install-docs
+.endif
+
.include <bsd.port.mk>