aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-reslog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/p5-reslog/Makefile')
-rw-r--r--sysutils/p5-reslog/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/p5-reslog/Makefile b/sysutils/p5-reslog/Makefile
new file mode 100644
index 000000000000..eb2370e2e2a8
--- /dev/null
+++ b/sysutils/p5-reslog/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-reslog
+# Date created: 2008/05/18
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= reslog
+PORTVERSION= 3.16
+CATEGORIES= sysutils perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Locale/IMACAT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Reverse-resolve IP in Apache log files
+
+BUILD_DEPENDS= p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
+ p5-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic \
+ p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-ExtUtils-MakeMaker>=0:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+MAN1= reslog.1
+
+PLIST_FILES= bin/reslog \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/reslog/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/reslog
+
+.include <bsd.port.mk>