aboutsummaryrefslogtreecommitdiff
path: root/sysutils/plasma6-kinfocenter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/plasma6-kinfocenter/Makefile')
-rw-r--r--sysutils/plasma6-kinfocenter/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/sysutils/plasma6-kinfocenter/Makefile b/sysutils/plasma6-kinfocenter/Makefile
new file mode 100644
index 000000000000..610fb8687d96
--- /dev/null
+++ b/sysutils/plasma6-kinfocenter/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= kinfocenter
+DISTVERSION= ${KDE_PLASMA_VERSION}
+CATEGORIES= sysutils kde kde-plasma
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= View information about your computer's hardware
+
+RUN_DEPENDS= clinfo:devel/clinfo \
+ glxinfo:graphics/mesa-demos \
+ lscpu:sysutils/lscpu \
+ vulkaninfo:graphics/vulkan-tools \
+ xdpyinfo:x11/xdpyinfo
+
+USES= cmake gettext gl kde:6 qt:6 tar:xz
+USE_GL= gl opengl
+USE_KDE= auth colorscheme completion config configwidgets coreaddons \
+ doctools i18n jobwidgets kcmutils kio package service solid \
+ widgetsaddons \
+ ecm:build \
+ kirigami2:run systemsettings:run
+USE_QT= base
+
+.include <bsd.port.mk>