aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/pot/Makefile')
-rw-r--r--sysutils/pot/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/sysutils/pot/Makefile b/sysutils/pot/Makefile
index 14d63762bfa7..11cb1b3dfebd 100644
--- a/sysutils/pot/Makefile
+++ b/sysutils/pot/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pot
-DISTVERSION= 0.14.0
+DISTVERSION= 0.15.0
PORTREVISION= 0
CATEGORIES= sysutils
@@ -13,6 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= potnet:sysutils/potnet \
ncat:security/nmap \
freebsd-release-manifests>0:misc/freebsd-release-manifests
+TEST_DEPENDS= flock:sysutils/flock
USE_RC_SUBR= pot pot_early
@@ -28,6 +29,8 @@ ZSH_DESC= Zsh Autocompletion support
OPTIONS_DEFAULT= ZSH
OPTIONS_SUB= yes
+TEST_WRKSRC= ${WRKSRC}/tests
+
PORTDOCS= *
do-install:
@@ -53,6 +56,9 @@ do-install:
do-install-ZSH-on:
( cd ${WRKSRC}/share/zsh && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/zsh)
+do-test:
+ ( cd ${TEST_WRKSRC} && ./test-suite.sh )
+
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/share/doc/pot/Installation.md \