aboutsummaryrefslogtreecommitdiff
path: root/sysutils/slurm-wlm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/slurm-wlm/Makefile')
-rw-r--r--sysutils/slurm-wlm/Makefile47
1 files changed, 35 insertions, 12 deletions
diff --git a/sysutils/slurm-wlm/Makefile b/sysutils/slurm-wlm/Makefile
index f2f506152ea0..2829d7f80504 100644
--- a/sysutils/slurm-wlm/Makefile
+++ b/sysutils/slurm-wlm/Makefile
@@ -15,11 +15,9 @@ COMMENT= Simple Linux Utility for Resource Management
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libsysinfo.so:devel/libsysinfo \
- libhwloc.so:devel/hwloc \
- libmunge.so:security/munge \
- librrd.so:databases/rrdtool \
- libhdf5.so:science/hdf5
+LIB_DEPENDS= libjson-c.so:devel/json-c \
+ libsysinfo.so:devel/libsysinfo \
+ libmunge.so:security/munge
USERS= slurm
GROUPS= ${USERS}
@@ -29,16 +27,41 @@ USE_LDCONFIG= yes
USE_RC_SUBR= slurmctld slurmd
PLIST_SUB= PORTVERSION="${PORTVERSION}"
INSTALL_TARGET= install-strip
-USES= gmake libtool perl5 pkgconfig python tar:bz2
-GTK2_USE= GNOME=glib20,gtk20
-MYSQL_USE= MYSQL=yes
-CFLAGS+= -I${WRKSRC}/slurm -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lsysinfo -lkvm
+USES= gmake libtool pkgconfig python:build tar:bz2
+USE_perl5= configure
-OPTIONS_DEFINE= DOCS MYSQL GTK2
+OPTIONS_DEFINE= CURL DOCS GTK2 HDF5 HWLOC IPMI MYSQL RRD
+OPTIONS_DEFAULT=HDF5 HWLOC
OPTIONS_SUB= yes
-GTK2_DESC= Build GUI config tool sview
+CURL_DESC= Require cURL for elasticsearch plugins
+GTK2_DESC= Build sview GUI config tool
+HDF5_DESC= Job profiling using HDF5
+HWLOC_DESC= Portable hardware locality
+IPMI_DESC= IPMI engergy consumption accounting
+RRD_DESC= RRD external sensor data collection
+
+GTK2_USE= GNOME=glib20,gtk20
+
+CURL_LIB_DEPENDS= libcurl.so:ftp/curl
+CURL_CONFIGURE_with= libcurl
+
+HDF5_LIB_DEPENDS= libhdf5.so:science/hdf5
+HDF5_CONFIGURE_WITH= hdf5
+
+HWLOC_LIB_DEPENDS= libhwloc.so:devel/hwloc
+HWLOC_CONFIGURE_WITH= hwloc
+
+IPMI_LIB_DEPENDS= libfreeipmi.so:sysutils/freeipmi
+IPMI_CONFIGURE_WITH= freeipmi
+
+RRD_LIB_DEPENDS= librrd.so:databases/rrdtool
+RRD_CONFIGURE_WITH= rrdtool
+
+MYSQL_USE= MYSQL=yes
+
+CFLAGS+= -I${WRKSRC}/slurm -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lsysinfo -lkvm
# SLURM's configure enables interactive jobs if pty.h exists. Replacing
# #include <pty.h> with appropriate headers will therefore not work, so instead