aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xen-guest-tools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/xen-guest-tools/Makefile')
-rw-r--r--sysutils/xen-guest-tools/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/sysutils/xen-guest-tools/Makefile b/sysutils/xen-guest-tools/Makefile
index f396858c417c..c31ceacfd24a 100644
--- a/sysutils/xen-guest-tools/Makefile
+++ b/sysutils/xen-guest-tools/Makefile
@@ -1,7 +1,7 @@
PORTNAME= xen-guest-tools
#PORTVERSION= 4.14.0
PORTVERSION= 4.16.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://downloads.xenproject.org/release/xen/${PORTVERSION}/
DISTNAME= xen-${PORTVERSION}
@@ -54,7 +54,9 @@ PLIST_FILES= bin/xen-detect \
bin/xenstore-watch \
bin/xenstore-write \
lib/libxenstore.so.4.0 \
- lib/libxentoolcore.so.1.0
+ lib/libxenstore.so.4 \
+ lib/libxentoolcore.so.1.0 \
+ lib/libxentoolcore.so.1
post-patch:
${REINPLACE_CMD} -e 's;=xen tools stubdom docs;=tools;' \
@@ -79,5 +81,7 @@ do-install:
cd ${STAGEDIR}${PREFIX}/bin/ && ${LN} -f xenstore xenstore-rm
cd ${STAGEDIR}${PREFIX}/bin/ && ${LN} -f xenstore xenstore-watch
cd ${STAGEDIR}${PREFIX}/bin/ && ${LN} -f xenstore xenstore-write
+ cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -f libxenstore.so.4.0 libxenstore.so.4
+ cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -f libxentoolcore.so.1.0 libxentoolcore.so.1
.include <bsd.port.mk>