aboutsummaryrefslogtreecommitdiff
path: root/textproc/expat2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/expat2/Makefile')
-rw-r--r--textproc/expat2/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/textproc/expat2/Makefile b/textproc/expat2/Makefile
index ebd5a7f6aae8..2ebaa278d7c4 100644
--- a/textproc/expat2/Makefile
+++ b/textproc/expat2/Makefile
@@ -1,10 +1,11 @@
PORTNAME= expat
-DISTVERSION= 2.4.8
+DISTVERSION= 2.6.2
CATEGORIES= textproc
MASTER_SITES= https://github.com/libexpat/libexpat/releases/download/R_${DISTVERSION:S|.|_|g}/
MAINTAINER= desktop@FreeBSD.org
COMMENT= XML 1.0 parser written in C
+WWW= https://github.com/libexpat/libexpat
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -12,13 +13,19 @@ LICENSE_FILE= ${WRKSRC}/COPYING
TEST_DEPENDS= bash:shells/bash
USES= cpe libtool pathfix python:test tar:xz
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
CPE_VENDOR= libexpat_project
CPE_PRODUCT= libexpat
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
-CONFIGURE_ARGS= --without-docbook --without-examples
INSTALL_TARGET= install-strip
+TEST_TARGET= check
+
+PLIST_SUB= EXPAT_VERSION=${DISTVERSION}
+
+CONFIGURE_ARGS= --without-docbook \
+ --without-examples
OPTIONS_DEFINE= DOCS STATIC TEST
OPTIONS_SUB= yes
@@ -28,11 +35,5 @@ STATIC_CONFIGURE_ENABLE= static
TEST_USES= shebangfix
SHEBANG_FILES= test-driver-wrapper.sh tests/udiffer.py tests/xmltest.sh
TEST_CONFIGURE_WITH= tests
-TEST_TARGET= check
-
-PLIST_SUB= EXPAT_VERSION=${DISTVERSION}
-
-post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/xmlwf.1 ${STAGEDIR}${MANPREFIX}/man/man1/
.include <bsd.port.mk>