aboutsummaryrefslogtreecommitdiff
path: root/textproc/libtranslate
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libtranslate')
-rw-r--r--textproc/libtranslate/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/textproc/libtranslate/Makefile b/textproc/libtranslate/Makefile
index 22c54068f0f5..5cfec483ebef 100644
--- a/textproc/libtranslate/Makefile
+++ b/textproc/libtranslate/Makefile
@@ -19,7 +19,7 @@ USE_GETOPT_LONG= yes
USE_GNOME= glib20 gnomehack intlhack
GNU_CONFIGURE= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -50,4 +50,7 @@ PLIST_SUB+= TALKFILTERS=""
LIB_DEPENDS+= talkfilters:${PORTSDIR}/misc/talkfilters
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+
.include <bsd.port.post.mk>