aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Lingua-EN-Inflect-Number
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Lingua-EN-Inflect-Number')
-rw-r--r--textproc/p5-Lingua-EN-Inflect-Number/Makefile37
-rw-r--r--textproc/p5-Lingua-EN-Inflect-Number/distinfo2
-rw-r--r--textproc/p5-Lingua-EN-Inflect-Number/pkg-descr4
-rw-r--r--textproc/p5-Lingua-EN-Inflect-Number/pkg-plist9
4 files changed, 52 insertions, 0 deletions
diff --git a/textproc/p5-Lingua-EN-Inflect-Number/Makefile b/textproc/p5-Lingua-EN-Inflect-Number/Makefile
new file mode 100644
index 000000000000..8ec9807eab51
--- /dev/null
+++ b/textproc/p5-Lingua-EN-Inflect-Number/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Lingua-EN-Inflect-Number
+# Date created: Apr 4 2004
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+
+PORTNAME= Lingua-EN-Inflect-Number
+PORTVERSION= 1.1
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Lingua
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Force number of words to singular or plural
+
+BUILD_DEPENDS= ${SITE_PERL}/Lingua/EN/Inflect.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Lingua::EN::Inflect::Number.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);$$1/;' \
+ -e '$$_="" if /use 5.006/;' \
+ -e '$$_="" if /use warnings/;' \
+ ${WRKSRC}/Number.pm
+
+post-configure:
+ ${PERL} -pi -e 's,/usr/local/,\$$(PREFIX)/,g' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Lingua-EN-Inflect-Number/distinfo b/textproc/p5-Lingua-EN-Inflect-Number/distinfo
new file mode 100644
index 000000000000..70a31255d34b
--- /dev/null
+++ b/textproc/p5-Lingua-EN-Inflect-Number/distinfo
@@ -0,0 +1,2 @@
+MD5 (Lingua-EN-Inflect-Number-1.1.tar.gz) = bcee940ef603da93e7da11d8eecad409
+SIZE (Lingua-EN-Inflect-Number-1.1.tar.gz) = 3003
diff --git a/textproc/p5-Lingua-EN-Inflect-Number/pkg-descr b/textproc/p5-Lingua-EN-Inflect-Number/pkg-descr
new file mode 100644
index 000000000000..187791cb8c07
--- /dev/null
+++ b/textproc/p5-Lingua-EN-Inflect-Number/pkg-descr
@@ -0,0 +1,4 @@
+This module extends the functionality of Lingua::EN::Inflect with
+three new functions available for export.
+
+WWW: http://search.cpan.org/dist/Lingua-EN-Inflect-Number/
diff --git a/textproc/p5-Lingua-EN-Inflect-Number/pkg-plist b/textproc/p5-Lingua-EN-Inflect-Number/pkg-plist
new file mode 100644
index 000000000000..e899b4df00e1
--- /dev/null
+++ b/textproc/p5-Lingua-EN-Inflect-Number/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Lingua/EN/Inflect/Number.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Lingua/EN/Inflect/Number/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Lingua/EN/Inflect/Number
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Lingua/EN/Inflect 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Lingua/EN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Lingua 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Lingua/EN/Inflect 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Lingua/EN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Lingua 2>/dev/null || true