aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-faust-cchardet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-faust-cchardet/Makefile')
-rw-r--r--textproc/py-faust-cchardet/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/textproc/py-faust-cchardet/Makefile b/textproc/py-faust-cchardet/Makefile
new file mode 100644
index 000000000000..23af33824f41
--- /dev/null
+++ b/textproc/py-faust-cchardet/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= faust-cchardet
+DISTVERSION= 2.1.19
+CATEGORIES= textproc python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= High speed universal character encoding detector
+WWW= https://github.com/faust-streaming/cChardet
+
+LICENSE= MPL11
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}pkgconfig>0:devel/py-pkgconfig@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 cython concurrent autoplist pytest
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/cchardet/_cchardet${PYTHON_EXT_SUFFIX}.so
+
+.include <bsd.port.mk>