aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-mistune/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-mistune/Makefile')
-rw-r--r--textproc/py-mistune/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/textproc/py-mistune/Makefile b/textproc/py-mistune/Makefile
index ca1c6807f220..a52d4c5bbbc1 100644
--- a/textproc/py-mistune/Makefile
+++ b/textproc/py-mistune/Makefile
@@ -1,5 +1,6 @@
PORTNAME= mistune
PORTVERSION= 2.0.4
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,14 +12,14 @@ WWW= https://github.com/lepture/mistune
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
USES= cpe python:3.6+
-USE_PYTHON= autoplist concurrent distutils unittest
+USE_PYTHON= autoplist concurrent pep517 unittest
NO_ARCH= yes
CPE_VENDOR= mistune_project
-post-patch:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
-
.include <bsd.port.mk>