aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-sphinxext-opengraph/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-sphinxext-opengraph/Makefile')
-rw-r--r--textproc/py-sphinxext-opengraph/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/py-sphinxext-opengraph/Makefile b/textproc/py-sphinxext-opengraph/Makefile
new file mode 100644
index 000000000000..eebd3e1b9686
--- /dev/null
+++ b/textproc/py-sphinxext-opengraph/Makefile
@@ -0,0 +1,28 @@
+# Created by: Alexis Praga <alexis.praga@free.fr>
+
+PORTNAME= sphinxext-opengraph
+PORTVERSION= 0.4.2
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alexis.praga@free.fr
+COMMENT= Sphinx extension to generate OpenGraph metadata
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=2.0:textproc/py-sphinx@${PY_FLAVOR}
+
+USES= python:3.6+
+# LICENSE and tests are not packaged yet, using github as a fallback
+USE_GITHUB= yes
+GH_ACCOUNT= wpilibsuite
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+do-test:
+ cd ${WRKSRC}/ && ${PYTHON_CMD} -m pytest -v -rs -o addopts=
+
+.include <bsd.port.mk>