aboutsummaryrefslogtreecommitdiff
path: root/textproc/rubygem-nokogiri111/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/rubygem-nokogiri111/Makefile')
-rw-r--r--textproc/rubygem-nokogiri111/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/textproc/rubygem-nokogiri111/Makefile b/textproc/rubygem-nokogiri111/Makefile
new file mode 100644
index 000000000000..8eb75fe7eddd
--- /dev/null
+++ b/textproc/rubygem-nokogiri111/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= nokogiri
+PORTVERSION= 1.11.7
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 111
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= HTML, XML, SAX, and Reader parser
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error
+# Do not add mini_portile2 to RUN_DEPENDS. Read ext/nokogiri/extconf.rb
+# and https://lists.freebsd.org/pipermail/svn-ports-all/2019-March/209423.html
+RUN_DEPENDS= rubygem-pkg-config>=1.1.7:devel/rubygem-pkg-config \
+ rubygem-racc>=1.4<2:devel/rubygem-racc
+
+USES= cpe gem gnome pkgconfig gettext-runtime
+USE_GNOME= libxml2 libxslt
+USE_RUBY= yes
+
+CONFIGURE_ARGS= --use-system-libraries
+
+post-install:
+ ${RM} ${STAGEDIR}${PREFIX}/bin/nokogiri
+ ${FIND} ${STAGEDIR}${PREFIX}/${GEMS_BASE_DIR} -name '*.o' -o -name '*.so' | ${XARGS} ${STRIP_CMD}
+ ${RMDIR} ${STAGEDIR}${PREFIX}/${GEM_LIB_DIR}/ports/
+
+PORTSCOUT= limit:^1\.11\.
+
+.include <bsd.port.mk>