aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/zorba/Makefile8
-rw-r--r--textproc/zorba/files/patch-CMakeLists.txt2
2 files changed, 2 insertions, 8 deletions
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
index ba18e075093d..b18682a0124a 100644
--- a/textproc/zorba/Makefile
+++ b/textproc/zorba/Makefile
@@ -50,12 +50,6 @@ PLIST_SUB+= FULLVERSION=${PORTVERSION} \
MIDVERSION=${PORTVERSION:R} \
MINVERSION=${PORTVERSION:R:R}
-.if exists(/usr/lib/libexecinfo.so)
-LOC_EXECINFO= /usr/lib/libexecinfo.so
-.else
-LOC_EXECINFO= ${LOCALBASE}/lib/libexecinfo.so
-.endif
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPHP}
@@ -91,7 +85,7 @@ BUILD_DEPENDS+= swig2.0:devel/swig20
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|%%LIBEXECINFO%%|${LOC_EXECINFO}|' \
+ ${REINPLACE_CMD} \
-e 's|FreeBSD|${OPSYS}|g' ${WRKSRC}/CMakeLists.txt
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/cmake_modules/FindPHP5.cmake
diff --git a/textproc/zorba/files/patch-CMakeLists.txt b/textproc/zorba/files/patch-CMakeLists.txt
index d116c45a837d..6a53f85f2d92 100644
--- a/textproc/zorba/files/patch-CMakeLists.txt
+++ b/textproc/zorba/files/patch-CMakeLists.txt
@@ -18,7 +18,7 @@
+# execinfo
+#
+IF(FREEBSD)
-+ SET(requiredlibs ${requiredlibs} "%%LIBEXECINFO%%")
++ SET(requiredlibs ${requiredlibs} "/usr/lib/libexecinfo.so")
+ENDIF(FREEBSD)
+
+#