aboutsummaryrefslogtreecommitdiff
path: root/ukrainian/hunspell/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ukrainian/hunspell/Makefile')
-rw-r--r--ukrainian/hunspell/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/ukrainian/hunspell/Makefile b/ukrainian/hunspell/Makefile
new file mode 100644
index 000000000000..9565ed0dde16
--- /dev/null
+++ b/ukrainian/hunspell/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: hunspell
+# Date created: 2011-07-20
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hunspell
+PORTVERSION= 1.6.5
+CATEGORIES= ukrainian textproc
+MASTER_SITES= SF/ispell-uk/spell-uk/${PORTVERSION}
+DISTNAME= spell-uk-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Hunspell ukrainian dictionnary
+
+BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
+
+WRKSRC= ${WRKDIR}/spell-uk-${PORTVERSION}
+USE_GMAKE= yes
+USE_PERL5_BUILD= yes
+
+ALL_TARGET= myspell
+
+PLIST_FILES= share/hunspell/uk_UA.aff \
+ share/hunspell/uk_UA.dic
+PLIST_DIRS= share/hunspell
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/hunspell
+ @${INSTALL_DATA} ${WRKSRC}/dist/myspell-uk-${PORTVERSION}/uk_UA.aff \
+ ${WRKSRC}/dist/myspell-uk-${PORTVERSION}/uk_UA.dic \
+ ${PREFIX}/share/hunspell/
+.include <bsd.port.mk>