aboutsummaryrefslogtreecommitdiff
path: root/www/castget/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/castget/Makefile')
-rw-r--r--www/castget/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/www/castget/Makefile b/www/castget/Makefile
index 55549c71ef1a..81eab9be00b7 100644
--- a/www/castget/Makefile
+++ b/www/castget/Makefile
@@ -1,26 +1,34 @@
PORTNAME= castget
-DISTVERSION= 2.0.1
-PORTREVISION= 2
+DISTVERSION= 2.0.1-20220211
+PORTREVISION= 1
CATEGORIES= www
-MASTER_SITES= SAVANNAH
MAINTAINER= ports@FreeBSD.org
COMMENT= Command-line podcast downloader
+WWW= https://castget.johndal.com/
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING.LIB
-LIB_DEPENDS= libid3.so:audio/id3lib \
+BUILD_DEPENDS= ronn:textproc/rubygem-ronn
+LIB_DEPENDS= libtag.so:audio/taglib \
libcurl.so:ftp/curl
-USES= compiler:c11 gnome libtool localbase:ldflags pkgconfig tar:bzip2
-USE_LDCONFIG= yes
+USES= autoreconf compiler:c11 gmake gnome groff libtool \
+ localbase:ldflags pkgconfig
USE_GNOME= glib20 libxml2
-# CONFIGURE_ARGS= --disable-static
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= mlj
+GH_TAGNAME= da9727d
+
+#CONFIGURE_ARGS= --disable-static
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
INSTALL_TARGET= install-strip
PLIST_FILES= bin/castget \
- man/man1/castget.1.gz man/man5/castgetrc.5.gz
+ share/man/man1/castget.1.gz share/man/man5/castgetrc.5.gz
.include <bsd.port.mk>