aboutsummaryrefslogtreecommitdiff
path: root/www/firefox
diff options
context:
space:
mode:
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-wayland-proxy15
2 files changed, 16 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 651c4f8ba9eb..6d64abfa085d 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -1,6 +1,6 @@
PORTNAME= firefox
DISTVERSION= 123.0
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 2
CATEGORIES= www wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}${DISTVERSIONSUFFIX}/source \
diff --git a/www/firefox/files/patch-wayland-proxy b/www/firefox/files/patch-wayland-proxy
new file mode 100644
index 000000000000..d9cb16bd2215
--- /dev/null
+++ b/www/firefox/files/patch-wayland-proxy
@@ -0,0 +1,15 @@
+--- third_party/wayland-proxy/wayland-proxy.cpp.orig 2024-02-29 09:10:59.939556000 +0100
++++ third_party/wayland-proxy/wayland-proxy.cpp 2024-02-29 15:07:13.914375000 +0100
+@@ -318,10 +318,10 @@
+ }
+
+ bool ProxiedConnection::ConnectToCompositor() {
+- if (!(mCompositorFlags & POLLOUT)) {
++ /* if (!(mCompositorFlags & POLLOUT)) {
+ // Try again later
+ return true;
+- }
++ }*/
+
+ struct sockaddr_un addr = {};
+ addr.sun_family = AF_UNIX;