aboutsummaryrefslogtreecommitdiff
path: root/www/hs-yesod-bin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/hs-yesod-bin/Makefile')
-rw-r--r--www/hs-yesod-bin/Makefile207
1 files changed, 112 insertions, 95 deletions
diff --git a/www/hs-yesod-bin/Makefile b/www/hs-yesod-bin/Makefile
index d44cb780b4a6..2e10b4a288ed 100644
--- a/www/hs-yesod-bin/Makefile
+++ b/www/hs-yesod-bin/Makefile
@@ -1,9 +1,10 @@
PORTNAME= yesod-bin
-PORTVERSION= 1.6.2.1
+PORTVERSION= 1.6.2.3
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Yesod helper executable
+WWW= https://www.yesodweb.com/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -11,124 +12,140 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cabal
USE_CABAL= HUnit-1.6.2.0 \
- OneTuple-0.3.1_2 \
- QuickCheck-2.14.2 \
+ OneTuple-0.4.1.1_1 \
+ QuickCheck-2.14.3 \
StateVar-1.2.2 \
- aeson-2.0.3.0 \
- ansi-terminal-0.11.3 \
- ansi-wl-pprint-0.6.9_3 \
+ aeson-2.2.1.0_1 \
+ ansi-terminal-1.1 \
+ ansi-terminal-types-1.1 \
appar-0.1.8 \
asn1-encoding-0.9.6_2 \
asn1-parse-0.9.5 \
asn1-types-0.3.4 \
- assoc-1.0.2_2 \
- async-2.2.4_1 \
- attoparsec-0.14.4_1 \
+ assoc-1.1_1 \
+ async-2.2.5 \
+ attoparsec-0.14.4_5 \
auto-update-0.1.6 \
- base-compat-0.12.1 \
- base-compat-batteries-0.12.1_2 \
- base-orphans-0.8.6 \
- base64-bytestring-1.2.1.0 \
- basement-0.0.14 \
- bifunctors-5.5.12 \
- blaze-builder-0.4.2.2_1 \
- bsb-http-chunked-0.0.0.4_3 \
+ base-orphans-0.9.1 \
+ base16-bytestring-1.0.2.0_1 \
+ base64-bytestring-1.2.1.0_1 \
+ basement-0.0.16 \
+ bifunctors-5.6.1_2 \
+ bitvec-1.1.5.0 \
+ blaze-builder-0.4.2.3 \
+ bsb-http-chunked-0.0.0.4_4 \
byteorder-1.0.4 \
- cabal-doctest-1.0.9 \
+ cabal-doctest-1.0.9_3 \
call-stack-0.4.0 \
case-insensitive-1.2.1.0 \
- cereal-0.5.8.2 \
- clock-0.8.3 \
+ cborg-0.2.10.0 \
+ cereal-0.5.8.3 \
+ clock-0.8.4 \
colour-2.3.6 \
- comonad-5.0.8_1 \
- conduit-1.3.4.2 \
+ comonad-5.0.8_2 \
+ conduit-1.3.5 \
conduit-extra-1.3.6 \
- connection-0.3.1_1 \
contravariant-1.5.5 \
- cookie-0.4.5 \
- cryptonite-0.30 \
+ cookie-0.4.6 \
+ crypto-token-0.1.1 \
+ crypton-0.34 \
+ crypton-connection-0.3.2 \
+ crypton-x509-1.7.6_1 \
+ crypton-x509-store-1.6.9 \
+ crypton-x509-system-1.6.7 \
+ crypton-x509-validation-1.6.12 \
data-default-class-0.1.2.0 \
- data-fix-0.3.2_2 \
+ data-fix-0.3.2_5 \
distributive-0.6.2.1_1 \
- dlist-1.0 \
- easy-file-0.2.2 \
- fast-logger-3.1.1 \
- file-embed-0.0.15.0 \
- fsnotify-0.3.0.1_2 \
- hashable-1.4.0.2 \
+ dlist-1.0_1 \
+ easy-file-0.2.5 \
+ fast-logger-3.2.2 \
+ file-embed-0.0.16.0 \
+ fsnotify-0.4.1.0 \
+ generically-0.1.1_2 \
+ half-0.3.1_1 \
+ hashable-1.4.3.0_1 \
hourglass-0.2.12 \
- hsc2hs-0.68.8 \
- http-client-0.7.11_1 \
- http-client-tls-0.3.6.1 \
+ hsc2hs-0.68.10_1 \
+ http-client-0.7.16 \
+ http-client-tls-0.3.6.3 \
http-date-0.0.11 \
- http-reverse-proxy-0.6.0.1 \
- http-types-0.12.3 \
- http2-3.0.3 \
- indexed-traversable-0.1.2_1 \
- indexed-traversable-instances-0.1.1 \
- integer-logarithms-1.0.3.1_2 \
+ http-reverse-proxy-0.6.0.2 \
+ http-types-0.12.4 \
+ http2-5.1.2 \
+ indexed-traversable-0.1.3 \
+ indexed-traversable-instances-0.1.1.2_2 \
+ integer-conversion-0.1.0.1_1 \
+ integer-logarithms-1.0.3.1_5 \
iproute-1.7.12 \
- libyaml-0.1.2 \
- memory-0.17.0 \
- mime-types-0.1.0.9 \
- mono-traversable-1.0.15.3 \
- network-3.1.2.7 \
- network-byte-order-0.1.6_1 \
- network-uri-2.6.4.1 \
+ libyaml-0.1.2_1 \
+ memory-0.18.0 \
+ mime-types-0.1.2.0 \
+ monad-control-1.0.3.1 \
+ mono-traversable-1.0.17.0 \
+ network-3.1.4.0_1 \
+ network-byte-order-0.1.7 \
+ network-control-0.0.2 \
+ network-uri-2.6.4.2_1 \
old-locale-1.0.0.7_2 \
- old-time-1.1.0.3_2 \
- optparse-applicative-0.17.0.0 \
+ old-time-1.1.0.4 \
+ optparse-applicative-0.18.1.0 \
pem-0.2.4 \
- primitive-0.7.4.0 \
+ prettyprinter-1.7.1 \
+ prettyprinter-ansi-terminal-1.1.3 \
+ primitive-0.9.0.0 \
project-template-0.2.1.0 \
- psqueues-0.2.7.3 \
- random-1.2.1.1 \
- resourcet-1.2.5 \
+ psqueues-0.2.8.0 \
+ random-1.2.1.2 \
+ recv-0.1.0 \
+ resourcet-1.3.0 \
+ safe-exceptions-0.1.7.4_1 \
say-0.1.0.1 \
- scientific-0.3.7.0_2 \
- semialign-1.2.0.1_1 \
- semigroupoids-5.3.7 \
- simple-sendfile-0.2.30 \
+ scientific-0.3.7.0_7 \
+ semialign-1.3_1 \
+ semigroupoids-6.0.0.1_1 \
+ serialise-0.2.6.1_1 \
+ simple-sendfile-0.2.32 \
socks-0.6.1 \
- split-0.2.3.4_2 \
- splitmix-0.1.0.4 \
- streaming-commons-0.2.2.4 \
- strict-0.4.0.1_4 \
- tagged-0.8.6.1_2 \
- tar-0.5.1.1_5 \
- text-short-0.1.5 \
- th-abstraction-0.4.3.0 \
- th-compat-0.1.3_1 \
- these-1.1.1.1_5 \
- time-compat-1.9.6.1_3 \
- time-manager-0.0.0 \
- tls-1.5.7 \
- tls-session-manager-0.0.4 \
- transformers-compat-0.7.1_1 \
- typed-process-0.2.8.0_1 \
- unix-compat-0.6 \
- unix-time-0.4.7 \
- unliftio-0.2.22.0 \
- unliftio-core-0.2.0.1_2 \
- unordered-containers-0.2.19.1 \
- uuid-types-1.0.5_2 \
- vault-0.3.1.5_1 \
- vector-0.12.3.1_2 \
- vector-algorithms-0.8.0.4_1 \
- wai-3.2.3 \
- wai-extra-3.1.12.1 \
+ split-0.2.5 \
+ splitmix-0.1.0.5 \
+ streaming-commons-0.2.2.6_1 \
+ strict-0.5_1 \
+ tagged-0.8.8 \
+ tar-0.5.1.1_10 \
+ text-iso8601-0.1_1 \
+ text-short-0.1.5_3 \
+ th-abstraction-0.6.0.0_1 \
+ th-compat-0.1.4_4 \
+ these-1.2_1 \
+ time-compat-1.9.6.1_6 \
+ time-manager-0.0.1 \
+ tls-2.0.1_1 \
+ tls-session-manager-0.0.5_1 \
+ transformers-base-0.4.6 \
+ transformers-compat-0.7.2 \
+ typed-process-0.2.11.1 \
+ unix-compat-0.7.1 \
+ unix-time-0.4.12 \
+ unliftio-0.2.25.0 \
+ unliftio-core-0.2.1.0_3 \
+ unordered-containers-0.2.20_1 \
+ utf8-string-1.0.2 \
+ uuid-types-1.0.5.1 \
+ vault-0.3.1.5_6 \
+ vector-0.13.1.0 \
+ vector-algorithms-0.9.0.1_3 \
+ vector-stream-0.1.0.1 \
+ wai-3.2.4 \
+ wai-extra-3.1.14 \
wai-logger-2.4.0 \
- warp-3.3.20 \
- warp-tls-3.3.2 \
- witherable-0.4.2_2 \
+ warp-3.4.0 \
+ warp-tls-3.4.4 \
+ witherable-0.4.2_4 \
word8-0.1.3 \
- x509-1.7.6 \
- x509-store-1.6.9 \
- x509-system-1.6.7 \
- x509-validation-1.6.12 \
- yaml-0.11.8.0 \
- zlib-0.6.3.0
+ yaml-0.11.11.2_2 \
+ zlib-0.7.0.0
-EXECUTABLES= yesod
+CABAL_EXECUTABLES= yesod
.include <bsd.port.mk>