aboutsummaryrefslogtreecommitdiff
path: root/www/httrack/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/httrack/Makefile')
-rw-r--r--www/httrack/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/www/httrack/Makefile b/www/httrack/Makefile
index 87d2fe531cac..dd5af7b9e1b6 100644
--- a/www/httrack/Makefile
+++ b/www/httrack/Makefile
@@ -1,32 +1,34 @@
PORTNAME= httrack
-PORTVERSION= 3.49.2
-PORTREVISION= 1
+PORTVERSION= 3.49.5
CATEGORIES= www
-MASTER_SITES= https://download.httrack.com/ \
- https://mirror.httrack.com/ \
- https://mirror.httrack.com/historical/ \
- http://download.httrack.com/ \
- http://mirror.httrack.com/ \
- http://mirror.httrack.com/historical/ \
- LOCAL/sunpoet
+
+PATCH_SITES= https://github.com/xroche/httrack/commit/
+PATCHFILES= ce2d2ce810cb1bbaf1c587a3947c31adb47d5244.patch:-p1
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Easy-to-use offline browser utility and website copier
+WWW= https://www.httrack.com/ \
+ https://github.com/xroche/httrack
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-OPTIONS_DEFINE= DOCS ICONS
-OPTIONS_SUB= yes
+USES= alias cpe gmake iconv libtool shebangfix ssl
CONFIGURE_ARGS= --docdir=${DOCSDIR} --with-zlib=/usr
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= ${PREFIX}/lib/httrack
-USES= alias cpe gmake iconv libtool shebangfix ssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= xroche
+GH_TUPLE= xroche:coucal:73ada07:xroche_coucal/src/coucal
SHEBANG_FILES= src/webhttrack
+OPTIONS_DEFINE= DOCS ICONS
+OPTIONS_SUB= yes
+
ICONS_USES= gnome
.include <bsd.port.options.mk>