aboutsummaryrefslogtreecommitdiff
path: root/www/linux-opera/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/linux-opera/Makefile')
-rw-r--r--www/linux-opera/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index cc50d0628edb..2d1f291fc60e 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -6,16 +6,16 @@
#
PORTNAME= opera
-PORTVERSION= 7.11.20030515
-PORTREVISION= 2
+PORTVERSION= 7.21.20031013
CATEGORIES= www linux
-MASTER_SITES= ftp://ftp.opera.com/pub/opera/linux/711/final/en/i386/static/
+MASTER_SITES= ftp://ftp.opera.com/pub/opera/linux/721/final/en/i386/static/
PKGNAMEPREFIX= linux-
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.2/-2/}.1-static-qt.i386
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.2003/-2003/}.1-static-qt.i386
MAINTAINER= mezz7@cox.net
COMMENT= A blazingly fast, full-featured, standards-compliant browser
+CONFLICTS= opera-*
RESTRICTED= "not redistributable; commercial software"
RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXm.so.2:${PORTSDIR}/x11-toolkits/linux-openmotif
@@ -43,13 +43,13 @@ PLIST_SUB+= GNOME:=""
PLIST_SUB+= GNOME:="@comment "
.endif
-.if exists(${X11BASE}/share/applnk/Internet)
+.if exists(${LOCALBASE}/share/applnk/Internet)
PLIST_SUB+= KDE:=""
.else
PLIST_SUB+= KDE:="@comment "
.endif
-.if exists(${X11BASE}/share/applnk/Networking)
+.if exists(${LOCALBASE}/share/applnk/Networking)
PLIST_SUB+= KDE2:=""
.else
PLIST_SUB+= KDE2:="@comment "
@@ -62,8 +62,9 @@ PLIST_SUB+= GNOMELNK:="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|%%X11PREFIX%%|${X11BASE}|g ; \
- s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/install.sh
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/install.sh
do-install:
(cd ${WRKSRC} && ./install.sh --prefix=${PREFIX})