aboutsummaryrefslogtreecommitdiff
path: root/www/minio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/minio/Makefile')
-rw-r--r--www/minio/Makefile37
1 files changed, 19 insertions, 18 deletions
diff --git a/www/minio/Makefile b/www/minio/Makefile
index 3f635298daab..214d7ec5b6a5 100644
--- a/www/minio/Makefile
+++ b/www/minio/Makefile
@@ -12,8 +12,8 @@ LICENSE= APACHE20
USES= compiler go:modules
USE_GITHUB= yes
-GHTAG= RELEASE.2019-06-15T23-07-18Z
-COMMIT_ID= 99bf4d0c429f04dbd013ba98840d07b759ae1702
+GHTAG= RELEASE.2019-08-29T00-25-01Z
+COMMIT_ID= eb18c82976251d9a0c0730df27e10204c89beae2
GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
Azure:azure-sdk-for-go:v27.0.0:azure_azure_sdk_for_go/vendor/github.com/Azure/azure-sdk-for-go \
Azure:go-autorest:v11.7.0:azure_go_autorest/vendor/github.com/Azure/go-autorest \
@@ -22,6 +22,7 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
alecthomas:participle:v0.2.1:alecthomas_participle/vendor/github.com/alecthomas/participle \
aliyun:aliyun-oss-go-sdk:86c17b95fcd5:aliyun_aliyun_oss_go_sdk/vendor/github.com/aliyun/aliyun-oss-go-sdk \
apache:thrift:v0.12.0:apache_thrift/vendor/git.apache.org/thrift.git \
+ aws:aws-sdk-go:v1.20.21:aws_aws_sdk_go/vendor/github.com/aws/aws-sdk-go \
bcicen:jstream:16c1f8af81c2:bcicen_jstream/vendor/github.com/bcicen/jstream \
beorn7:perks:3a771d992973:beorn7_perks/vendor/github.com/beorn7/perks \
census-ecosystem:opencensus-go-exporter-ocagent:v0.5.0:census_ecosystem_opencensus_go_exporter_ocagent/vendor/contrib.go.opencensus.io/exporter/ocagent \
@@ -46,13 +47,13 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
go-yaml:yaml:v2.2.2:go_yaml_yaml/vendor/gopkg.in/yaml.v2 \
gogo:protobuf:v1.2.1:gogo_protobuf/vendor/github.com/gogo/protobuf \
golang:appengine:v1.4.0:golang_appengine/vendor/google.golang.org/appengine \
- golang:crypto:5c40567a22f8:golang_crypto/vendor/golang.org/x/crypto \
- golang:net:3f473d35a33a:golang_net/vendor/golang.org/x/net \
+ golang:crypto:60c769a6c586:golang_crypto/vendor/golang.org/x/crypto \
+ golang:net:74dc4d7220e7:golang_net/vendor/golang.org/x/net \
golang:oauth2:e64efc72b421:golang_oauth2/vendor/golang.org/x/oauth2 \
golang:protobuf:v1.3.1:golang_protobuf/vendor/github.com/golang/protobuf \
golang:snappy:v0.0.1:golang_snappy/vendor/github.com/golang/snappy \
golang:sync:112230192c58:golang_sync/vendor/golang.org/x/sync \
- golang:sys:93c9922d18ae:golang_sys/vendor/golang.org/x/sys \
+ golang:sys:fde4db37ae7a:golang_sys/vendor/golang.org/x/sys \
golang:text:v0.3.2:golang_text/vendor/golang.org/x/text \
golang:time:9d24e82272b4:golang_time/vendor/golang.org/x/time \
gomodule:redigo:v2.0.0:gomodule_redigo/vendor/github.com/gomodule/redigo \
@@ -75,19 +76,20 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
hashicorp:golang-lru:v0.5.1:hashicorp_golang_lru/vendor/github.com/hashicorp/golang-lru \
hashicorp:hcl:v1.0.0:hashicorp_hcl/vendor/github.com/hashicorp/hcl \
hashicorp:vault:v1.1.0:hashicorp_vault/vendor/github.com/hashicorp/vault \
- howeyc:gopass:bf9dde6d0d2c:howeyc_gopass/vendor/github.com/howeyc/gopass \
inconshreveable:go-update:8152e7eb6ccf:inconshreveable_go_update/vendor/github.com/inconshreveable/go-update \
jcmturner:aescts:v1.0.1:jcmturner_aescts/vendor/gopkg.in/jcmturner/aescts.v1 \
jcmturner:dnsutils:v1.0.1:jcmturner_dnsutils/vendor/gopkg.in/jcmturner/dnsutils.v1 \
jcmturner:gofork:dc7c13fece03:jcmturner_gofork/vendor/github.com/jcmturner/gofork \
- jcmturner:gokrb5:v5.3.0:jcmturner_gokrb5/vendor/gopkg.in/jcmturner/gokrb5.v5 \
- jcmturner:rpc:v0.0.2:jcmturner_rpc/vendor/gopkg.in/jcmturner/rpc.v0 \
- json-iterator:go:v1.1.6:json_iterator_go/vendor/github.com/json-iterator/go \
+ jcmturner:goidentity:v3.0.0:jcmturner_goidentity/vendor/gopkg.in/jcmturner/goidentity.v3 \
+ jcmturner:rpc:v1.1.0:jcmturner_rpc/vendor/gopkg.in/jcmturner/rpc.v1 \
+ jmespath:go-jmespath:c2b33e8439af:jmespath_go_jmespath/vendor/github.com/jmespath/go-jmespath \
klauspost:compress:v1.5.0:klauspost_compress/vendor/github.com/klauspost/compress \
klauspost:cpuid:v1.2.1:klauspost_cpuid/vendor/github.com/klauspost/cpuid \
klauspost:pgzip:v1.2.1:klauspost_pgzip/vendor/github.com/klauspost/pgzip \
klauspost:readahead:v1.3.0:klauspost_readahead/vendor/github.com/klauspost/readahead \
klauspost:reedsolomon:v1.9.1:klauspost_reedsolomon/vendor/github.com/klauspost/reedsolomon \
+ konsorten:go-windows-terminal-sequences:v1.0.1:konsorten_go_windows_terminal_sequences/vendor/github.com/konsorten/go-windows-terminal-sequences \
+ kurin:blazer:cf2f27cc0be3:kurin_blazer/vendor/github.com/kurin/blazer \
lib:pq:v1.0.0:lib_pq/vendor/github.com/lib/pq \
mailru:easyjson:03f2033d19d5:mailru_easyjson/vendor/github.com/mailru/easyjson \
marstr:guid:v1.1.0:marstr_guid/vendor/github.com/marstr/guid \
@@ -96,12 +98,12 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
mattn:go-runewidth:v0.0.4:mattn_go_runewidth/vendor/github.com/mattn/go-runewidth \
matttproud:golang_protobuf_extensions:v1.0.1:matttproud_golang_protobuf_extensions/vendor/github.com/matttproud/golang_protobuf_extensions \
miekg:dns:v1.1.8:miekg_dns/vendor/github.com/miekg/dns \
- minio:blazer:2081f5bf0465:minio_blazer/vendor/github.com/minio/blazer \
- minio:cli:v1.20.0:minio_cli/vendor/github.com/minio/cli \
- minio:dsync:v1.0.0:minio_dsync/vendor/github.com/minio/dsync \
- minio:hdfs:v3.0.0:minio_hdfs/vendor/github.com/minio/hdfs/v3 \
+ minio:cli:v1.21.0:minio_cli/vendor/github.com/minio/cli \
+ minio:dsync:v2.0.0:minio_dsync/vendor/github.com/minio/dsync/v2 \
+ minio:gokrb5:v7.2.5:minio_gokrb5/vendor/github.com/minio/gokrb5/v7 \
+ minio:hdfs:v3.0.1:minio_hdfs/vendor/github.com/minio/hdfs/v3 \
minio:highwayhash:v1.0.0:minio_highwayhash/vendor/github.com/minio/highwayhash \
- minio:lsync:v0.1.0:minio_lsync/vendor/github.com/minio/lsync \
+ minio:lsync:v1.0.1:minio_lsync/vendor/github.com/minio/lsync \
minio:mc:f4bb0b8850cb:minio_mc/vendor/github.com/minio/mc \
minio:minio-go:5325257a208f:minio_minio_go/vendor/github.com/minio/minio-go \
minio:minio-go:v6.0.29:dup_minio_go/vendor/github.com/minio/minio-go/v6 \
@@ -110,8 +112,6 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
minio:sio:v0.2.0:minio_sio/vendor/github.com/minio/sio \
mitchellh:go-homedir:v1.1.0:mitchellh_go_homedir/vendor/github.com/mitchellh/go-homedir \
mitchellh:mapstructure:v1.1.2:mitchellh_mapstructure/vendor/github.com/mitchellh/mapstructure \
- modern-go:concurrent:bacd9c7ef1dd:modern_go_concurrent/vendor/github.com/modern-go/concurrent \
- modern-go:reflect2:v1.0.1:modern_go_reflect2/vendor/github.com/modern-go/reflect2 \
nats-io:nats.go:v1.8.0:nats_io_nats_go/vendor/github.com/nats-io/nats.go \
nats-io:nkeys:v0.0.2:nats_io_nkeys/vendor/github.com/nats-io/nkeys \
nats-io:nuid:v1.0.1:nats_io_nuid/vendor/github.com/nats-io/nuid \
@@ -126,12 +126,12 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
prometheus:client_model:fd36f4220a90:prometheus_client_model/vendor/github.com/prometheus/client_model \
prometheus:common:v0.2.0:prometheus_common/vendor/github.com/prometheus/common \
prometheus:procfs:bf6a532e95b1:prometheus_procfs/vendor/github.com/prometheus/procfs \
- rcrowley:go-metrics:3113b8401b8a:rcrowley_go_metrics/vendor/github.com/rcrowley/go-metrics \
+ rcrowley:go-metrics:9c2d0518ed81:rcrowley_go_metrics/vendor/github.com/rcrowley/go-metrics \
rjeczalik:notify:v0.9.2:rjeczalik_notify/vendor/github.com/rjeczalik/notify \
rs:cors:v1.6.0:rs_cors/vendor/github.com/rs/cors \
ryanuber:go-glob:v1.0.0:ryanuber_go_glob/vendor/github.com/ryanuber/go-glob \
satori:go.uuid:v1.2.0:satori_go_uuid/vendor/github.com/satori/go.uuid \
- segmentio:go-prompt:f0d19b6901ad:segmentio_go_prompt/vendor/github.com/segmentio/go-prompt \
+ sirupsen:logrus:v1.4.2:sirupsen_logrus/vendor/github.com/sirupsen/logrus \
skyrings:skyring-common:d1c0bb1cbd5e:skyrings_skyring_common/vendor/github.com/skyrings/skyring-common \
streadway:amqp:16ed540749f6:streadway_amqp/vendor/github.com/streadway/amqp \
tidwall:gjson:v1.2.1:tidwall_gjson/vendor/github.com/tidwall/gjson \
@@ -139,6 +139,7 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
tidwall:pretty:v1.0.0:tidwall_pretty/vendor/github.com/tidwall/pretty \
tidwall:sjson:v1.0.4:tidwall_sjson/vendor/github.com/tidwall/sjson \
uber-go:atomic:v1.3.2:uber_go_atomic/vendor/go.uber.org/atomic \
+ valyala:fastjson:v1.4.1:valyala_fastjson/vendor/github.com/valyala/fastjson \
valyala:tcplisten:ceec8f93295a:valyala_tcplisten/vendor/github.com/valyala/tcplisten
GO_BUILDFLAGS= -ldflags='\