aboutsummaryrefslogtreecommitdiff
path: root/www/mod_dav/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_dav/Makefile')
-rw-r--r--www/mod_dav/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/www/mod_dav/Makefile b/www/mod_dav/Makefile
new file mode 100644
index 000000000000..1fa3e8b79f65
--- /dev/null
+++ b/www/mod_dav/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: mod_dav (apache)
+# Version required: 0.9.12
+# Date created: Sun Oct 17, 1999
+# Whom: patrick@mindstep.com
+#
+# $FreeBSD$
+#
+
+DISTNAME= mod_dav-${DAV_VERSION}-${APACHE_VERSION}
+PKGNAME= mod_dav-${DAV_VERSION}
+CATEGORIES= www
+MASTER_SITES= http://www.webdav.org/mod_dav/
+
+MAINTAINER= patrick@mindstep.com
+
+BUILD_DEPENDS= ${PREFIX}/sbin/apxs:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${PREFIX}/sbin/apxs:${PORTSDIR}/www/apache13
+
+# This port will work with the following version of Apache and anything newer.
+APACHE_VERSION= 1.3.6
+DAV_VERSION= 0.9.12
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --bindir=${PREFIX}/bin \
+ --sbindir=${PREFIX}/sbin \
+ --libexecdir=${PREFIX}/libexec/apache \
+ --mandir=${PREFIX}/man \
+ --sysconfdir=${PREFIX}/etc/apache \
+ --datadir=${PREFIX}/share/apache \
+ --includedir=${PREFIX}/include/apache \
+ --with-apxs=${PREFIX}/sbin/apxs
+
+CONFIGURE_ENV= CFLAGS='${CFLAGS}' \
+ PATH="${PREFIX}/bin:${PREFIX}/sbin:${PATH}"
+
+post-install:
+ ${INSTALL_DATA} ${FILESDIR}/apache.conf.mod_dav ${PREFIX}/etc/apache
+ @${ECHO_MSG} "*******************************************************"
+ @${ECHO_MSG} "* Please review the mod_dav configuration in the main"
+ @${ECHO_MSG} "* Apache configuration file."
+ @${ECHO_MSG} "* ${PREFIX}/etc/apache/apache.conf"
+ @${ECHO_MSG} "*"
+ @${ECHO_MSG} "* Look at the file ${PREFIX}/etc/apache/apache.conf.mod_dav"
+ @${ECHO_MSG} "* for indications on what to do."
+ @${ECHO_MSG} "*"
+ @${ECHO_MSG} "*******************************************************"
+
+.include <bsd.port.mk>