aboutsummaryrefslogtreecommitdiff
path: root/www/mod_http2-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_http2-devel/Makefile')
-rw-r--r--www/mod_http2-devel/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/www/mod_http2-devel/Makefile b/www/mod_http2-devel/Makefile
new file mode 100644
index 000000000000..1aa77701afc4
--- /dev/null
+++ b/www/mod_http2-devel/Makefile
@@ -0,0 +1,40 @@
+# Created by: Bernard Spil <brnrd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mod_http2-devel
+PORTVERSION= 1.2.7
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+
+MAINTAINER= brnrd@FreeBSD.org
+COMMENT= Early experience HTTP/2 module for Apache httpd
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= nghttp2>=1.2:${PORTSDIR}/www/nghttp2
+LIB_DEPENDS= libnghttp2.so:${PORTSDIR}/www/nghttp2
+
+USE_GITHUB= yes
+GH_ACCOUNT= icing
+GH_PROJECT= mod_h2
+
+USES= autoreconf libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-prefix=ext-
+CONFIGURE_ENV= CONFIG_SHELL=/bin/sh
+
+USE_APACHE= 24+
+MODULENAME= ${GH_PROJECT}
+
+CFLAGS+= -I${LOCALBASE}/include
+
+post-install:
+ # Rename mod_http2 to the mod_h2 to avoid conflict with Apache24
+ ${MV} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/mod_http2.so.0.0.0 \
+ ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/${MODULENAME}.so
+ ${RM} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/mod_http2.so
+ ${MV} ${STAGEDIR}${PORTDOCS}${PREFIX}/share/doc/mod_http2 \
+ ${STAGEDIR}${PORTDOCS}${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/${MODULENAME}.so
+
+.include <bsd.port.mk>