aboutsummaryrefslogtreecommitdiff
path: root/www/mozplugger/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mozplugger/Makefile')
-rw-r--r--www/mozplugger/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/www/mozplugger/Makefile b/www/mozplugger/Makefile
index 0a56ca0e59e9..b6abe5be49d6 100644
--- a/www/mozplugger/Makefile
+++ b/www/mozplugger/Makefile
@@ -3,16 +3,19 @@
PORTNAME= mozplugger
PORTVERSION= 2.1.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://mozplugger.mozdev.org/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= Framework for loading web content in external viewers
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= yes
USE_XORG= x11 xt
USES= desthack gmake webplugin:native
-SUB_FILES= pkg-message
WEBPLUGIN_FILES=mozplugger.so
MAKE_ENV= WEBPLUGINS_DIR="${WEBPLUGIN_DIR}"
@@ -22,4 +25,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|"/etc|"${PREFIX}/etc|g' \
${WRKSRC}/mozplugger.c
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mozplugger-*
+ @${STRIP_CMD} ${STAGEDIR}${WEBPLUGIN_DIR}/*.so
+
.include <bsd.port.mk>