aboutsummaryrefslogtreecommitdiff
path: root/www/p5-MojoX-Renderer-Xslate/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-MojoX-Renderer-Xslate/Makefile')
-rw-r--r--www/p5-MojoX-Renderer-Xslate/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/www/p5-MojoX-Renderer-Xslate/Makefile b/www/p5-MojoX-Renderer-Xslate/Makefile
new file mode 100644
index 000000000000..a3fc0cda3ffe
--- /dev/null
+++ b/www/p5-MojoX-Renderer-Xslate/Makefile
@@ -0,0 +1,23 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= MojoX-Renderer-Xslate
+PORTVERSION= 0.10
+CATEGORIES= www textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Text::Xslate renderer for for Mojolicious
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Mojolicious>=5.81:${PORTSDIR}/www/p5-Mojolicious \
+ p5-Text-Xslate>=0.2013:${PORTSDIR}/textproc/p5-Text-Xslate
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>