aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Plack-Middleware-Test-StashWarnings/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Plack-Middleware-Test-StashWarnings/Makefile')
-rw-r--r--www/p5-Plack-Middleware-Test-StashWarnings/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/www/p5-Plack-Middleware-Test-StashWarnings/Makefile b/www/p5-Plack-Middleware-Test-StashWarnings/Makefile
new file mode 100644
index 000000000000..03b9bb0ceb8a
--- /dev/null
+++ b/www/p5-Plack-Middleware-Test-StashWarnings/Makefile
@@ -0,0 +1,22 @@
+# Created by: Matthew Seaman <matthew@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Plack-Middleware-Test-StashWarnings
+PORTVERSION= 0.07
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Test your application's warnings
+
+BUILD_DEPENDS= p5-Plack>0:${PORTSDIR}/www/p5-Plack
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+regression-test: build
+ @cd ${WRKSRC} && ${MAKE} test
+
+.include <bsd.port.mk>