aboutsummaryrefslogtreecommitdiff
path: root/www/pear-HTTP_Request2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/pear-HTTP_Request2/Makefile')
-rw-r--r--www/pear-HTTP_Request2/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/www/pear-HTTP_Request2/Makefile b/www/pear-HTTP_Request2/Makefile
index 9f773de12c87..f344a9db4727 100644
--- a/www/pear-HTTP_Request2/Makefile
+++ b/www/pear-HTTP_Request2/Makefile
@@ -1,23 +1,27 @@
# Created by: Wen Heping <wenheping@gmail.com>
PORTNAME= HTTP_Request2
-PORTVERSION= 2.4.2
+DISTVERSION= 2.4.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www pear
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= PEAR classes providing an easy way to perform HTTP requests
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/docs/LICENSE
+
BUILD_DEPENDS= ${PEARDIR}/Net/URL2.php:net/pear-Net_URL2@${PHP_FLAVOR}
RUN_DEPENDS= ${PEARDIR}/Net/URL2.php:net/pear-Net_URL2@${PHP_FLAVOR}
+USES= pear
+
OPTIONS_DEFINE= CURL FILEINFO ZLIB
CURL_DESC= PHP CURL extension support
FILEINFO_DESC= PHP FILEINFO extension support
ZLIB_DESC= PECL ZLIB support
-USES= pear
-
CURL_USES= php
CURL_USE= PHP=curl
FILEINFO_USES= php