aboutsummaryrefslogtreecommitdiff
path: root/www/plasma5-plasma-browser-integration/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'www/plasma5-plasma-browser-integration/files/patch-CMakeLists.txt')
-rw-r--r--www/plasma5-plasma-browser-integration/files/patch-CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/www/plasma5-plasma-browser-integration/files/patch-CMakeLists.txt b/www/plasma5-plasma-browser-integration/files/patch-CMakeLists.txt
index 9310e9ff1c08..f9579b0fae19 100644
--- a/www/plasma5-plasma-browser-integration/files/patch-CMakeLists.txt
+++ b/www/plasma5-plasma-browser-integration/files/patch-CMakeLists.txt
@@ -1,11 +1,14 @@
---- CMakeLists.txt.orig 2019-11-28 17:30:00 UTC
+--- CMakeLists.txt.orig 2021-02-11 12:12:43 UTC
+++ CMakeLists.txt
-@@ -71,7 +71,7 @@ configure_file(org.kde.plasma.firefox_integration.json
+@@ -78,9 +78,9 @@ configure_file(org.kde.plasma.firefox_integration.json
# #chromium
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/org.kde.plasma.chrome_integration.json DESTINATION ${KDE_INSTALL_FULL_SYSCONFDIR}/chromium/native-messaging-hosts/ RENAME org.kde.plasma.browser_integration.json)
# #google-chrome
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/org.kde.plasma.chrome_integration.json DESTINATION ${KDE_INSTALL_FULL_SYSCONFDIR}/opt/chrome/native-messaging-hosts/ RENAME org.kde.plasma.browser_integration.json)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/org.kde.plasma.chrome_integration.json DESTINATION ${KDE_INSTALL_FULL_SYSCONFDIR}/chrome/native-messaging-hosts/ RENAME org.kde.plasma.browser_integration.json)
+ # Microsoft Edge
+-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/org.kde.plasma.chrome_integration.json DESTINATION ${KDE_INSTALL_FULL_SYSCONFDIR}/opt/edge/native-messaging-hosts/ RENAME org.kde.plasma.browser_integration.json)
++install(FILES ${CMAKE_CURRENT_BINARY_DIR}/org.kde.plasma.chrome_integration.json DESTINATION ${KDE_INSTALL_FULL_SYSCONFDIR}/edge/native-messaging-hosts/ RENAME org.kde.plasma.browser_integration.json)
# firefox
-
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/org.kde.plasma.firefox_integration.json DESTINATION ${MOZILLA_DIR}/native-messaging-hosts/ RENAME org.kde.plasma.browser_integration.json)
+